This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Tasks not defined after install

Discussion specific to symfony 1.1.x stable

Tasks not defined after install

by maestro_pete » Tue Jul 29, 2008 9:03 am

Resolved
http://trac.symfony-project.org/wiki/InstallingSymfonyOnMacO SXWithPHPBinaryFromEntropy
This wiki guide is out of date.

Also, the guide does not seem to specify the version of symfony used anywhere on the page, so there is no way for noobs like myself to know any better.

It took me long enough of messing up the book tutorial to find the specific linked tutorial for mac because all of the words in the title are one giant word. (top notch seo there)

...then several hours of reinstalling symfony and then php and pear over and over again nit picking different incorrect stabs in the dark with the mac install guide.

I will be happy to put together a comprehensive wiki page on installing symfony on mac, cause the documentation so far kinda isn't so hot.

If I am wrong about this and the "new" task is correct not "app:generate" please do inform me.

----------------------

hi am brand new to this framework and really looking forward to trying it out.

I am running Mac OS X 10.4 and default install of apache and an entrophy PHP 5.2.4 install.

I have followed this guide to a T. http://trac.symfony-project.org/wiki/InstallingSymfonyOnMacO SXWithPHPBinaryFromEntropy

Code: Select all
$ pear -V
PEAR Version: 1.7.2
PHP Version: 5.2.4
Zend Engine Version: 2.2.0
Running on: Darwin G4 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh

$ php -v
PHP 5.2.4 (cli) (built: Aug 31 2007 23:57:08)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies


Everything goes smooth installing with PEAR (I have to run all my commands as sudo) until I go to make a new project. (I haven't gotten past this point yet)


Code: Select all
$ symfony -V
symfony version 1.1.0 (/usr/local/php5/lib/php/symfony)
$ symfony new sfdemo                             
  Task "new" is not defined. 


Task "new" is not defined comes up in a big red box. same with all the commands after it.



Any Ideas?

EDIT: after checking the tasks it doesn't look like 'new' is even defined. I don't know anything about this since I have not yet been able to use the framework at all.

Here is a list of what was installed via PEAR. is this correct?


Code: Select all
Available tasks:
  :help               Displays help for a task (h)
  :list               Lists tasks
cache
  :clear              Clears the cache (cc, clear-cache)
configure
  :author             Configure project author
  :database           Configure database DSN
generate
  :app                Generates a new application (init-app)
  :module             Generates a new module (init-module)
  :project            Generates a new project (init-project)
  :task               Creates a skeleton class for a new task
i18n
  :extract            Extracts i18n strings from php files
  :find               Finds non "i18n ready" strings in an application
log
  :clear              Clears log files (log-purge)
  :rotate             Rotates an application log files (log-rotate)
plugin
  :add-channel        Add a new PEAR channel
  :install            Installs a plugin (plugin-install)
  :list               Lists installed plugins (plugin-list)
  :uninstall          Uninstalls a plugin (plugin-uninstall)
  :upgrade            Upgrades a plugin (plugin-upgrade)
project
  :clear-controllers  Clears all non production environment controllers (clear-controllers)
  :deploy             Deploys a project to another server (sync)
  :disable            Disables an application in a given environment (disable)
  :enable             Enables an application in a given environment (enable)
  :freeze             Freezes symfony libraries (freeze)
  :permissions        Fixes symfony directory permissions (permissions, fix-perms)
  :unfreeze           Unfreezes symfony libraries (unfreeze)
  :upgrade1.1         Upgrade a symfony project to the 1.1 symfony release
propel
  :build-all          Generates Propel model, SQL and initializes the database (propel-build-all)
  :build-all-load     Generates Propel model, SQL, initializes database, and load data (propel-build-all-load)
  :build-db           Creates database for current model (propel-build-db)
  :build-forms        Creates form classes for the current model
  :build-model        Creates classes for the current model (propel-build-model)
  :build-schema       Creates a schema.xml from an existing database (propel-build-schema)
  :build-sql          Creates SQL for the current model (propel-build-sql)
  :data-dump          Dumps data to the fixtures directory (propel-dump-data)
  :data-load          Loads data from fixtures directory (propel-load-data)
  :generate-crud      Generates a Propel CRUD module (propel-generate-crud)
  :init-admin         Initializes a Propel admin module (propel-init-admin)
  :insert-sql         Inserts SQL for current model (propel-insert-sql)
  :schema-to-xml      Creates schema.xml from schema.yml (propel-convert-yml-schema)
  :schema-to-yml      Creates schema.yml from schema.xml (propel-convert-xml-schema)
test
  :all                Launches all tests (test-all)
  :functional         Launches functional tests (test-functional)
  :unit               Launches unit tests (test-unit)
maestro_pete
Junior Member
 
Posts: 1
Joined: Tue Jul 29, 2008 7:05 am

Re: Tasks not defined after install

by varuntaliyan » Wed Jun 02, 2010 12:40 pm

Hi maestro_pete,

I know you must have solved the problem till now, and must be having good command over symfony till now but i m posting it for the reference of other newbees.

I also got the same error and i resolved it by removing spaces after generate ie i changed my command from "symfony generate : project myproject" to "symfony generate:project myproject" and it works fine.

A humble request to everyone, even if anyone doesnot replay to your problem, still be kind to post the solution whenever you finds it.
varuntaliyan
Junior Member
 
Posts: 1
Joined: Wed Jun 02, 2010 12:27 pm
Location: INDIA

Re: Tasks not defined after install

by halfer » Wed Jun 02, 2010 12:42 pm

@varuntaliyan - you're right about wanting people to post solutions that they find themselves! However this post is about two years old, so it is probably not worth chasing ;)~ ;-)~ :wink:
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK