This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

sfDoctrineGuardPlugin and php5.1.6

Discussion specific to symfony 1.1.x stable

sfDoctrineGuardPlugin and php5.1.6

by Atagyz » Wed Jul 28, 2010 11:30 am

Hi everybody,

i'm facing a strange problem since few days.

i'm working on an application on symfony 1.1, working with php 5.1.6. On my dev environment, i'm on php 5.2.x and everything works fine.

But when I try the app on production environment, with php 5.1.6, I have some problem on sfGuard signin : apache crashes !

With some time of debug, I found that in sfGuardPlugin signin methode (/lib/user/sfGuardSecurityUser.php), if I comment the addCredential line (74) OR the $user->save() line (78), I don't have this problem anymore.

Someone have already has this problem ?

Thx for your attention.
Atagyz
Junior Member
 
Posts: 3
Joined: Wed Jul 28, 2010 11:14 am

Re: sfDoctrineGuardPlugin and php5.1.6

by halfer » Wed Jul 28, 2010 11:34 am

I strongly recommend upgrading your version of PHP. It is said that the 5.x series only became stable from 5.2.x onwards, and 5.1.6 really is quite outdated now.

If you are using 5.1.6 because you're using Red Hat, upgrade it anyway. We're doing this, and have bumped PHP up to 5.2.11 with very little fuss.
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK

Re: sfDoctrineGuardPlugin and php5.1.6

by Atagyz » Wed Jul 28, 2010 11:43 am

I'm totaly agree with that ^^

But unfortunatly, we don't have the choice, we don't have the hand on the production server and administrators do not want to make any upgrade of php ... =/
Atagyz
Junior Member
 
Posts: 3
Joined: Wed Jul 28, 2010 11:14 am

Re: sfDoctrineGuardPlugin and php5.1.6

by halfer » Wed Jul 28, 2010 12:27 pm

If it's a hosting company, then change your host. Or, if it's a dedicated server in your IT department, this is an internal political problem rather than a technical one.

I believe 5.1.6 was the official minimum version for 1.0 (not sure about 1.1 or 1.2) but I wouldn't use it now. We ran it on Windows for a while, but felt we had more confidence in the stack when we went to 5.2.4, even on Windows.

If you really must make do with 5.1.6 (and again I don't recommend it) then install it in your dev environment, and see if you can reproduce the problem. You might find switching from your current MPM to another solves the problem (i.e. Apache 2 Handler, FastCGI, fcgid, etc).

Obviously if you want detailed help, you'll need to provide details of your live environment.
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK