This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Help upgrading to 1.1

Discussion specific to symfony 1.1.x stable

Help upgrading to 1.1

by geoffreyfishing » Sat Feb 05, 2011 8:31 pm

I know that 1.1 is outdated, but my problem deals with upgrading.

I installed askeet on my webserver, and it was quite buggy and outdated. I know that it is old, but there is nothing else like it on the web. (Couple of things written in ruby & python, but nothing in PHP). So instead of reinventing the wheel, I just installed askeet.

Now, my plan was to slowly upgrade askeet (one upgrade per day or so), until the code was using the latest release, and then fix all the bugs.

Unfortunately, I haven't even gotten past the first release. I upgrade to 1.1, follow the steps, and get a 500 error.

I've looked at all the apache logs, symfony logs, etc. Nothing. I can't even figure out where the problem originates.

Can someone please give me some advice?
geoffreyfishing
Senior Member
 
Posts: 106
Joined: Wed Dec 29, 2010 7:49 pm

Re: Help upgrading to 1.1

by geoffreyfishing » Sun Feb 06, 2011 10:59 pm

Well, I guess this is just too complicated.
geoffreyfishing
Senior Member
 
Posts: 106
Joined: Wed Dec 29, 2010 7:49 pm

Re: Help upgrading to 1.1

by claudia_k » Mon Feb 07, 2011 2:19 pm

I do not have the slightest clue about askeet or symfony 1.1 but unless it is very different from symfony 1.4 you should be able to see details about your 500 error if you use the dev environment. instead of the production environment. So instead of calling the index.php file call the frontend_dev.php file.

Good luck

Claudia
claudia_k
Faithful Member
 
Posts: 265
Joined: Mon Jun 21, 2010 8:12 pm
Location: Luxembourg

Re: Help upgrading to 1.1

by geoffreyfishing » Tue Feb 08, 2011 12:49 am

Thanks!

Now getting this error:

Code: Select all
Warning: require(C:\AskHH\lib\vendor\symfony\lib\config\sfPhpConfigHandler.class.php) [function.require]: failed to open stream: No such file or directory in C:\AskHH\lib\vendor\symfony\lib\autoload\sfAutoload.class.php on line 165

Fatal error: require() [function.require]: Failed opening required 'C:\AskHH\lib\vendor\symfony\lib\config\sfPhpConfigHandler.class.php' (include_path='.;C:\Program Files\XAMPP\php\PEAR') in C:\AskHH\lib\vendor\symfony\lib\autoload\sfAutoload.class.php on line 165


But this is something that I can diagnose! Will update here on my debugging progress, but if anyone cares to comment, then you are welcome to.
geoffreyfishing
Senior Member
 
Posts: 106
Joined: Wed Dec 29, 2010 7:49 pm

Re: Help upgrading to 1.1

by geoffreyfishing » Tue Feb 08, 2011 1:04 am

Such an idiot! Needed to clear the cache.
geoffreyfishing
Senior Member
 
Posts: 106
Joined: Wed Dec 29, 2010 7:49 pm