This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

sfJqueryReloadedPlugin after installation missing symbolic links

Forum to discuss ExtJS and other JS plugins

sfJqueryReloadedPlugin after installation missing symbolic links

by flurdulis » Fri Jan 22, 2010 3:45 am

I am having an issue with installing sfJqueryReloadedPlugin. Every time it installs everything and skips the part with symbolic links.

Warning: symlink(): Could not fetch file information(error 3) in C:\Users\emusin
a\xampp\htdocs\sfproject2\lib\vendor\symfony\lib\task\sfFile system.class.php on
line 224

I've tried everything, and removed registry for it, created symbolic links manually (it's windows), and I am still not able to get jQuery to work. Basically, the path that is included to jQuery is not being found, because a symbolic link would say:

link ../plugins/sfJqueryReloadedPlugin/web

and I can't get this working... Is there a workaround where I could tweak maybe settings.yml to point to the correct location of the jquery JS file?


Thanks so much
flurdulis
Member
 
Posts: 52
Joined: Fri Jan 22, 2010 3:39 am

Re: sfJqueryReloadedPlugin after installation missing symbolic links

by tomor » Sun Jan 24, 2010 12:31 pm

mayby publish assets would help

or

manualy copy the content of the ../plugins/sfJqueryReloadedPlugin/web to the project /web folder.
tomor
Senior Member
 
Posts: 111
Joined: Tue Dec 22, 2009 9:25 am

Re: sfJqueryReloadedPlugin after installation missing symbolic links

by flurdulis » Wed Feb 03, 2010 9:13 pm

Only copying symbolic links from another successful project helped... I have Windows 7 and I guess creation of symbolic links fails within new windows. On my old windows XP symbolic links are created without issues.

Thanks again!
flurdulis
Member
 
Posts: 52
Joined: Fri Jan 22, 2010 3:39 am

Re: sfJqueryReloadedPlugin after installation missing symbolic links

by tomor » Thu Feb 04, 2010 3:22 pm

flurdulis wrote: Only copying symbolic links from another successful project helped... I have Windows 7 and I guess creation of symbolic links fails within new windows. On my old windows XP symbolic links are created without issues.

Thanks again!


You can create symbolic links on windows XP? How can I do that? Is that same as on the linxu machines? .. easy deploy then (1:1)?
tomor
Senior Member
 
Posts: 111
Joined: Tue Dec 22, 2009 9:25 am

Re: sfJqueryReloadedPlugin after installation missing symbolic links

by flurdulis » Fri Feb 05, 2010 12:40 am

If you have any successful project, just copy those links. I had Windows XP, and moved those links into another project from Windows 7. I am pretty sure you can copy links from any linux built symfony project and they will work as well...
flurdulis
Member
 
Posts: 52
Joined: Fri Jan 22, 2010 3:39 am

Re: sfJqueryReloadedPlugin after installation missing symbolic links

by halfer » Fri Feb 05, 2010 11:33 am

@tomor: from Windows2K, you can use "junction" to create links, which you can download free from the MS website. From Vista onwards I think you can use "mklink" and it's installed by default.
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK

Re: sfJqueryReloadedPlugin after installation missing symbolic links

by tomor » Fri Feb 05, 2010 12:08 pm

halfer wrote: @tomor: from Windows2K, you can use "junction" to create links, which you can download free from the MS website. From Vista onwards I think you can use "mklink" and it's installed by default.


And is this combatible with linux symlinks? ... I want it to be easily deployed form my developers machine (win XP) to a production server (unix).

By now I need to copy all stuff which need symlinks to a webfolder (I think it's done automatically on winXP by publish assets)
.. but it has an advantage that I can easily copy whole project to the production server and it just works - without any other changes.
tomor
Senior Member
 
Posts: 111
Joined: Tue Dec 22, 2009 9:25 am