This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

sfJqueryFormValidationPlugin doesn't work

Forum to discuss ExtJS and other JS plugins

sfJqueryFormValidationPlugin doesn't work

by atupmok » Thu Apr 28, 2011 2:04 pm

Hi!

I've done everything that the Readme Section of the sfJqueryFormValidationPlugin says, but it doesn't work. Does anyone know what the problem may be?

thx in advance
atupmok
Junior Member
 
Posts: 3
Joined: Tue Mar 15, 2011 1:17 am

Re: sfJqueryFormValidationPlugin doesn't work

by greeshmar » Tue Nov 22, 2011 9:13 am

I'm facing the same issue.

I don't use a yml file for validation. Validations are written inside the form classes.

In my case, I have a BaseNewsForm class, and a NewsForm class which extends the BaseNewsForm class.

The validations are written in these classes.

And in the action class I have;

public function executeNews(sfWebRequest $request)
{
$this->form = new NewsForm();
if ($request->isMethod(sfRequest::POST))
{
$this->processForm($request, $this->form);
}
}

protected function processForm(sfWebRequest $request, sfForm $form)
{
$form->bind($request->getParameter($form->getName()), $request->getFiles($form->getName()));
if ($form->isValid())
{
$news = $form->save();
}
}

And in the template, I have the form displayed.

The server side validation is working perfectly. But when I try to use sfJqueryFormValidationPlugin, it doesn't work at all.
It is not showing any error. But it doesn't work!!

Could someone help me sort the issue?

Thanks in advance..
greeshmar
Junior Member
 
Posts: 1
Joined: Tue Nov 22, 2011 6:57 am