This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

[sfLightboxPlugin] Official topic [support/bugs/features request]

Forum to discuss ExtJS and other JS plugins

Call to undefined function light_image()

by zebuloon » Sat Jul 14, 2007 8:54 am

Hi guys,

I am getting this error after follwing the installation guide :

Call to undefined function light_image()

settings.xml :

standard_helpers: [Partial, Cache, Form, Lightbox]
enabled_modules: [default, sfGuardAuth, sfGuardUser, sfGuardGroup, sfGuardPermission, sfLightboxPlugin]

My php is a copy paste from the guide.

What I am missing ?
Please be indulgent I am a beginner in Symfony...

Zébu

PS : sorry for the double post !
zebuloon
Junior Member
 
Posts: 2
Joined: Sat Jul 14, 2007 8:38 am

Re: [sfLightboxPlugin] New plugin !

by COil » Sat Jul 14, 2007 11:08 am

clear cache
COil
Faithful Member
 
Posts: 467
Joined: Wed Sep 06, 2006 6:08 pm



Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by ufasoli » Mon Apr 28, 2008 8:46 am

Hello there I decided to try out this plugin, which looks great, but I can't get it to work, I keep getting the following error message in my firebug console :

Code: Select all
                                            modalbox.js (line 303)
   fileBottomNavCloseImage is not defined
   initialize()modalbox.js (line 303)
   klass()prototype.js (line 48)
   initModalbox()modalbox.js (line 569)
   wrapper(load )prototype.js (line 3877)
   objBottomNavCloseImage.setAttribute('src', fileBottomNavCloseImage);



At first I thought the problem might come from lightbox.js loading before the prototype libraries, but I've checked that and I'm positive it's not..

The code that I'm using is the one provided in the wiki

Code: Select all

$link_options = array(
    'title' => 'sfLightboxPlugin',
    'size'  => '550x200',
    'speed' => '6'
);


echo light_modallink(
  '» Link to test the modal box «',
  'sfLightboxPlugin/modal',
  $link_options
);



Am I missing something here??


Thanks in advance

ufasoli
ufasoli
Junior Member
 
Posts: 24
Joined: Tue Feb 19, 2008 11:15 pm

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by Apophis » Mon Apr 28, 2008 10:36 pm

Hi

I've installed LightboxPlugin and made a sample page,
but it just opens the image instead of an overlay.

In Firebug I get an Scripting Error:
document.observe is not a function
http://shaolin.karazhan.network/sfLightboxPlugin/js/lightbox .js


The Header of the site is:
Quote: wrote: <link rel="shortcut icon" href="/favicon.ico" />
<script type="text/javascript" src="/sf/sf_web_debug/js/main.js"></script>

<script type="text/javascript" src="/sf/prototype/js/prototype.js"></script>
<script type="text/javascript" src="/sf/prototype/js/builder.js"></script>
<script type="text/javascript" src="/sf/prototype/js/effects.js"></script>
<script type="text/javascript" src="/sfLightboxPlugin/js/lightbox.js"></script>
<link rel="stylesheet" type="text/css" media="screen" href="/sf/sf_web_debug/css/main.css" />
<link rel="stylesheet" type="text/css" media="screen" href="/css/main.css" />
<link rel="stylesheet" type="text/css" media="screen" href="/sfLightboxPlugin/css/lightbox.css" />
</head>


I'm using Firefox 2.0.0.12 and the Demo Page is working.

Someone an idea why it's not working here?

edit: Never mind, found the problem, old version of Prototype libs.
Apophis
Junior Member
 
Posts: 15
Joined: Mon Oct 01, 2007 1:59 pm
Location: Lucerne/Switzerland

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by mazur » Tue Apr 29, 2008 7:38 am

hi, cosmicxdust can u explain how u solve this problem step by step, beacouse i'm new in symfony. and have no idea what to do :/
mazur
Member
 
Posts: 57
Joined: Tue Mar 04, 2008 1:18 pm

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by chrisbarnett » Thu May 01, 2008 4:09 pm

Hi, I think i'm getting the same problem. What version of prototype do you need to use the sfLightBoxPlugin? I tried to update but couldn't get it to work. How did you update yours?
chrisbarnett
Junior Member
 
Posts: 15
Joined: Fri Mar 28, 2008 4:28 pm
Location: Surrey

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by Apophis » Thu May 01, 2008 5:47 pm

chrisbarnett wrote: Hi, I think i'm getting the same problem. What version of prototype do you need to use the sfLightBoxPlugin? I tried to update but couldn't get it to work. How did you update yours?


You can eather download the Lightbox2 Package (http://www.huddletogether.com/projects/lightbox2/#download) and take the new version of the scripts from there and overwrite the ones that come with symfony (that's what I did).

Or you install the sfPrototypePlugin (http://trac.symfony-project.com/wiki/sfPrototypePlugin)
Apophis
Junior Member
 
Posts: 15
Joined: Mon Oct 01, 2007 1:59 pm
Location: Lucerne/Switzerland

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by zak2 » Wed May 21, 2008 3:00 pm

hi

this is a mistype in the modalbox.js on line 81
in the original code it's written as

Code: Select all
var fileBottomNavCloseImage = "images/close.gif";


but in the sfLightBoxPlugins's code it's

Code: Select all
var fileBottomModalCloseImage = "images/close.gif";


I haven't found any occurance of fileBottomModalCloseImage in the modalbox.js, so just correct the line to the original one, and you have a working lightModalBox in symfony.

bye
zak2
Junior Member
 
Posts: 1
Joined: Mon Oct 15, 2007 8:36 pm
Location: Budapest

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by ufasoli » Wed May 21, 2008 3:02 pm

yep I found out a while ago, I just forgot to close the post, thanks anyway

bye...

Ulises
ufasoli
Junior Member
 
Posts: 24
Joined: Tue Feb 19, 2008 11:15 pm

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by COil » Fri Jul 04, 2008 1:35 pm

For svn users, don't forget to update prototype to 1.6.0.2 before using the 1.0.7 version.
COil
Faithful Member
 
Posts: 467
Joined: Wed Sep 06, 2006 6:08 pm

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by lippo » Thu May 07, 2009 9:58 pm

The sfLightboxPlugin doesn't work for me.

I use the following versions:

Symfony 1.2.7
sfLightboxPlugin 1.0.7 (Lightbox v2.04)
sfProtoculousPlugin (Prototype 1.6.0.3)

I have installed the sfLightboxPlugin with PEAR and configure symfony like this:

config/ProjectConfiguration.class
Code: Select all
<?php

require_once(dirname(__FILE__) . '/../lib/symfony/autoload/sfCoreAutoload.class.php');
sfCoreAutoload::register();

class ProjectConfiguration extends sfProjectConfiguration
{
  public function setup()
  {
    // for compatibility / remove and enable only the plugins you want
    $this->enableAllPluginsExcept(array('sfDoctrinePlugin', 'sfCompat10Plugin', 'sfProtoculousPlugin'));
  }
}


But in Firebug I get an error:

Code: Select all
Object.extend is not a function
[Break on this error] }, window.LightboxOptions || {});
lightbox.js (Linie 63)


If I want to open this template:

Code: Select all
<?php use_helper('Lightbox'); ?>

<?php echo light_image_text(
  '&raquo; Click me to see the image !! &laquo;',
  'http://www.huddletogether.com/projects/lightbox2/images/image-2.jpg'
);


Of course I have made a cc and an asset.

Has anybody an idea?
lippo
Junior Member
 
Posts: 7
Joined: Thu Feb 12, 2009 10:09 am

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by COil » Thu May 07, 2009 10:19 pm

There is an error in the README the code should be:

Code: Select all
<?php

require_once(dirname(__FILE__) . '/../lib/symfony/autoload/sfCoreAutoload.class.php');
sfCoreAutoload::register();

class ProjectConfiguration extends sfProjectConfiguration
{
  public function setup()
  {
    // for compatibility / remove and enable only the plugins you want
    $this->enableAllPluginsExcept(array('sfDoctrinePlugin', 'sfCompat10Plugin'));
  }
}


The sfProtoculousPlugin must be enabled...

++
COil
Faithful Member
 
Posts: 467
Joined: Wed Sep 06, 2006 6:08 pm

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by lippo » Wed May 13, 2009 8:40 pm

What did you mean with 'enable'?

Not over the enableAllPluginsExcept-Property?
lippo
Junior Member
 
Posts: 7
Joined: Thu Feb 12, 2009 10:09 am

Re: [sfLightboxPlugin] Official topic [support/bugs/features request]

by COil » Thu May 14, 2009 11:01 pm

By enabling, i mean "not disabling it", as it was written in the previous version of the README. So... you have nothing to do if you are using sf 1.2 with a default configuration file.
COil
Faithful Member
 
Posts: 467
Joined: Wed Sep 06, 2006 6:08 pm