This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Running out of memory

Discussion relating to version 1.2.x stable

Running out of memory

by BStep » Tue Jul 17, 2012 6:42 pm

I have a site on symfony 1.2 and Sympal. Not sure which version of Sympal because I don't know how to check.

When saving a blog post in Sympal, it seems an infinite loop is triggered whereby calls to Doctrine's Parser.php are made repeatedly and the Apache process eventually uses all the memory allotted by PHP. Here's a more detailed description I posted on the Doctrine user group.

i've got Doctrine 1.0.10 running on symfony 1.2.8 (with sympal)...it
was symfony 1.2.8-DEV until a couple weeks ago when I realized the web
dev company built this production site on a DEV version of symfony
1.2.8, but anyway, it was just discovered that we can't add content to
the site since I upgraded to 1.2.8 final.

I tried going from 128mb to 256mb PHP memory limit size and got the
same result (the # of bytes in the memory size in the error message
increased, indicating the 256mb setting worked). I also tried symfony
doctrine:build-models, build-forms, build-filters, and symfony
cache:clear. Same result.

Apache is showing a PHP memory size limit exhausted error when saving
content. The error is in Parser.php, below:

[Fri Jun 22 14:14:26 2012] [error] [client 192.168.1.124] PHP Fatal
error: Allowed memory size of 134217728 bytes exhausted (tried to
allocate 64 bytes) in /var/www/X/symfony/lib/plugins/sfDoctrinePlugin/
lib/vendor/doctrine/Doctrine/Relation/Parser.php on line 235, referer:
http://www.X.com/index.php/admin/content/create/blog

The referenced section of code in Parser.php reads:

if ($recursive) {
$this->getRelations();

return $this->getRelation($alias, false);
} else {
throw new Doctrine_Table_Exception('Unknown relation alias
' . $alias);
}

Line 235 is the "throw" line.

Any thoughts? Thanks in advance.


I repeat here: Any thoughts? Thanks in advance. :)
BStep
Junior Member
 
Posts: 4
Joined: Fri Jan 08, 2010 5:41 pm