This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Column list already indexed, query fail!!

Discussion relating to version 1.3.x and 1.4.x

Column list already indexed, query fail!!

by zairankara » Fri Feb 28, 2014 4:39 pm

Hi everyone! I'm having problem with indexes:

Error: ORA-01408: such column list already indexed : CREATE INDEX "codigo" ON "customer_codes" ("codigo"). Failing Query: "CREATE INDEX "codigo" ON "customer_codes" ("codigo")". Failing Query: CREATE INDEX "codigo" ON "customer_codes" ("codigo")


schema.yml:


Customer:
actAs:
Timestampable: ~
columns:
codigo: { type: string(100), notnull:true, unique: true }


CustomerCodes:
actAs:
Timestampable: ~
columns:
codigo: { type: string(50), unique: true }
dealer: { type: string(10) }
relations:
Customer:
local: codigo
foreign: codigo
class: Customer
type: many
foreignType: one


I make an build --all --and-load then I have error: ORA-01408: such column list already indexed : CREATE INDEX "codigo" ON "customer_codes" ("codigo"). Failing Query: "CREATE INDEX "codigo" ON "customer_codes" ("codigo")". Failing Query: CREATE INDEX "codigo" ON "customer_codes" ("codigo")

What am I doing wrong?
zairankara
Junior Member
 
Posts: 2
Joined: Fri Feb 28, 2014 4:28 pm

Re: Column list already indexed, query fail!!

by zairankara » Tue Mar 18, 2014 7:27 pm

Nobody's there? help please!!
zairankara
Junior Member
 
Posts: 2
Joined: Fri Feb 28, 2014 4:28 pm

Re: Column list already indexed, query fail!!

by Jhonson » Mon Oct 13, 2014 7:43 am

CREATE INDEX "codigo" ON "customer_codes" ("codigo")
Gimi
Jhonson
Junior Member
 
Posts: 1
Joined: Mon Oct 13, 2014 7:39 am