This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Symfony 2.3, 2.6 OR 2.7 ?

New topics about Symfony 2 should go here

Symfony 2.3, 2.6 OR 2.7 ?

by eexbee » Thu May 14, 2015 10:30 pm

Hello

My Company wants to develop a CMS or CMF for the company based on symfony. I'm responsible for this project.

As a CMS should last a long time, which version of symfony is reasonable to be used?
I mean sf 2.7 is going to be the LTS version. On the other hand the last stable version is 2.6 but is not going to be LTS and 2.3 is yet LTS.

So It's a little bit confusing. It's hard to make a solid decision.

Is it good to use 2.3 and then upgrade to 2.7? Is it safe to upgrade base of a CMF/CMS like that?

Thanks for the help...
eexbee
Junior Member
 
Posts: 2
Joined: Wed Apr 17, 2013 4:16 pm

Re: Symfony 2.3, 2.6 OR 2.7 ?

by karop » Sun May 17, 2015 1:25 pm

I'm not experienced Symfony user but I went through documentation (The Book and The Cookbook) twice recently. There's few changes in 2.6, but not that many that it would be hard to do an upgrade I think. Here I mean all the boxes in the documentation like "New in 2.6", "From 2.5..."
Hope this will help.
karop
Junior Member
 
Posts: 13
Joined: Tue Oct 02, 2012 4:25 pm