This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Problem with annotation routing [solved]

Discuss Symfony 2 bundles here

Problem with annotation routing [solved]

by Lord_Luncher » Thu Jun 04, 2015 9:24 pm

Hello,

I hope anyone had the following problem before:

The problem: Only the first two routes in the DefaultController are available.

What i have done: I deployed symfony localy with XAMPP and added a bundle of mine. Checked everything, cleared the caches and uploaded it via ftp to a server (no ssh). On that server the everything is fine as long as i use the dev mode. When i use the prod mode the described problem appears.

I already switched the second and the third methods of the controller. Then the new second and the first route are available.

I hope someone could help me. I searched a lot and cant find a clue where the problem might be.

Kind Regards

Update: The problem was solved by switching to a newer PHP version. The problem occurs with version 5.4.x and disappears with version 5.6.x .
Lord_Luncher
Junior Member
 
Posts: 1
Joined: Thu Jun 04, 2015 9:15 pm