This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Symfony2 installation requires PHP 5.3.3

Discuss installing Symfony 2 here

Symfony2 installation requires PHP 5.3.3

by hvaras » Fri Dec 23, 2011 12:52 pm

Installing on PHP 5.3.2 server should be posible as Symfony2 requirements: http://symfony.com/doc/2.0/reference/requirements.html
But it is not.

"php app/check.php" shows all OK, except a warning for short tags.

After first config.php step, at app_dev.php/_configurator/ a fatal error shows up:

Code: Select all
ErrorException: Warning: SQLite3::exec(): database is locked in /vendor/symfony/src/Symfony/Component/HttpKernel/Profiler/SqliteProfilerStorage.php line 44

I just installed sqlite3, so I think the the reason may be that my php version (5.3.2) has no support for busytimeout: http://php.net/manual/en/sqlite3.busytimeout.php, php >= 5.3.3

This error shows in both Symfony 2.0.6 and 2.0.7 versions.

Update server php version is a big problem for many people nowadays, as current Ubuntu LTS (10.4) runs PHP 5.3.2.

As sqlite is only needed for profiler i solved this deactivating it at app/config/config_dev.yml replacing:
Code: Select all
    profiler: { only_exceptions: false }
with:
Code: Select all
    profiler: false

Is there knowledge on this issue by sf2 developers?
hvaras
Junior Member
 
Posts: 7
Joined: Wed Dec 21, 2011 4:59 pm

Re: Symfony2 installation requires PHP 5.3.3

by hvaras » Fri Dec 30, 2011 2:40 pm

It seems to be solved on 2.0.8.
hvaras
Junior Member
 
Posts: 7
Joined: Wed Dec 21, 2011 4:59 pm

Re: Symfony2 installation requires PHP 5.3.3

by hvaras » Fri Dec 30, 2011 3:01 pm

Sorry, i'm using 2.1.0-DEV, not current stable 2.0.8

Finally, profiler seems to work on php 5.3.2, but an annoying message is showing up now constantly in demo:

An error occurred while loading the web debug toolbar
Do you want to open the profiler

Profiler log does not show anything, any clues?
hvaras
Junior Member
 
Posts: 7
Joined: Wed Dec 21, 2011 4:59 pm

Re: Symfony2 installation requires PHP 5.3.3

by hvaras » Wed Feb 01, 2012 4:57 pm

Until now the problem is not solved in stable releases ...
hvaras
Junior Member
 
Posts: 7
Joined: Wed Dec 21, 2011 4:59 pm

Re: Symfony2 installation requires PHP 5.3.3

by althaus » Wed Feb 01, 2012 8:31 pm

It's really a strange issue and it's somehow related to that busytime thing. I just found this comment in the PHP manual:

If you get the error message saying "SQLite3::exec. database locked." You just need to define a busyTimeout to work around this.

http://php.net/manual/en/sqlite3.exec.php

I fear that this is getting quite complicated.

So what's happening if you're adding the proposed solution:

Code: Select all
parameters:
    kernel.cache_dir: '/tmp/sf-test'


btw: Github is the best place for the issue as it's related to the core. You prolly won't get someone deep in the code here in the forum.
althaus
Faithful Member
 
Posts: 605
Joined: Tue Oct 18, 2011 2:20 pm
Location: Germany

Re: Symfony2 installation requires PHP 5.3.3

by hvaras » Thu Feb 02, 2012 10:26 am

Setting:

Code: Select all
parameters:
    kernel.cache_dir: '/tmp/sf-test'

Causes to increase the response time too much. I mean more than 30secs to render a non complicated template...
hvaras
Junior Member
 
Posts: 7
Joined: Wed Dec 21, 2011 4:59 pm

Re: Symfony2 installation requires PHP 5.3.3

by hvaras » Thu Feb 02, 2012 2:32 pm

I also submitted this issue on github:
https://github.com/symfony/symfony/issues/3025
hvaras
Junior Member
 
Posts: 7
Joined: Wed Dec 21, 2011 4:59 pm

Re: Symfony2 installation requires PHP 5.3.3

by black7floyd » Thu Sep 25, 2014 11:13 am

Has anyone aware about fixing this issue. I am trying to install Symfony2 and getting the same error message here, which is very disturbing to me. Is there any way we can fix this issue? I have tried installing many times, but always getting B&G sprayer same error here.
black7floyd
Junior Member
 
Posts: 1
Joined: Fri Oct 12, 2012 7:59 am