This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

403 Forbidden on anything but /vendor & composer.json/.lock

Discuss installing Symfony 2 here

403 Forbidden on anything but /vendor & composer.json/.lock

by MrR7 » Tue Jan 22, 2013 9:39 pm

Hey guys!

I finally decided to try using a PHP framework in my next web application. I looked around on the internet, compared different frameworks and finally decided to give Symfony the first try. However, I am having problems installing it.

I tried to get it to run on my local Apache2 Server on Mac OS X 10.8. I am not using XAMPP or any package like that, but using the preinstalled Apache2 and PHP and a manually installed MySQL server.

When I move to Symfony's directory, I get the typical "index of" page of folders without an index.html file. However, it only shows me the folder /vendors, and both composer files (.json / .lock). Everything else does not show up there. Moreover, when I try to access "web/config.php" or any other file that actually exists on my hard drive, I get a 403 forbidden.

I already tried to reset the file permissions with CHMOD and followed this instructions. Neither of it helped.

Do you have any other ideas what I can try? :(

// PS: Please don't mind my English, I am not a native speaker.
MrR7
Junior Member
 
Posts: 1
Joined: Tue Jan 22, 2013 6:54 pm

Re: 403 Forbidden on anything but /vendor & composer.json/.l

by Tad » Tue Oct 01, 2013 10:19 pm

I am having the same issue, did you ever figure this one out?
Tad
Junior Member
 
Posts: 2
Joined: Tue Oct 01, 2013 10:16 pm

Re: 403 Forbidden on anything but /vendor & composer.json/.l

by Tad » Mon Oct 07, 2013 2:49 pm

I finally did figure this out, on OSX apache the .htaccess file is causing this.
Havent had a chance to check out why, i just renamed it temporarily to get access
Tad
Junior Member
 
Posts: 2
Joined: Tue Oct 01, 2013 10:16 pm

Re: 403 Forbidden on anything but /vendor & composer.json/.l

by gmakstutis » Mon Oct 14, 2013 10:38 am

I am also facing the same issue. I am using the stock Mac OS X apache, php 5.4 (installed via homebrew). Everything else on my setup seems to work fine, but I cannot get any of the Symfony directories (other than vendor) to be accessible via the web server.

Would really appreciate any advice
gmakstutis
Junior Member
 
Posts: 1
Joined: Mon Oct 14, 2013 10:34 am