This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Error running config.php

Discuss installing Symfony 2 here

Error running config.php

by Corkonian » Wed Oct 16, 2013 10:46 pm

Hi there, I'm an absolute beginner and I have installed Symfony Standard 2.3.6 and the initial Welcome screen works fine, but when I click the links at the bottom of the page I get:

Whoops, looks like something went wrong.

1/1FatalErrorException: Compile Error: Cannot redeclare class SessionHandlerInterface in /Library/WebServer/Documents/symfony/app/cache/dev/classes.php line 381

in /Library/WebServer/Documents/symfony/app/cache/dev/classes.php line 381


The output of my check.php is here:

********************************
* *
* Symfony requirements check *
* *
********************************

* Configuration file used by PHP: /etc/php.ini

** ATTENTION **
* The PHP CLI can use a different php.ini file
* than the one used with your web server.
* To be on the safe side, please also launch the requirements check
* from your web server using the web/config.php script.

** Mandatory requirements **

OK PHP version must be at least 5.3.3 (5.5.4 installed)
OK PHP version must not be 5.3.16 as Symfony won't work properly with it
OK Vendor libraries must be installed
OK app/cache/ directory must be writable
OK app/logs/ directory must be writable
OK date.timezone setting must be set
OK Configured default timezone "Europe/Dublin" must be supported by your installation of PHP
OK json_encode() must be available
OK session_start() must be available
OK ctype_alpha() must be available
OK token_get_all() must be available
OK simplexml_import_dom() must be available
OK detect_unicode must be disabled in php.ini
OK PCRE extension must be available

** Optional recommendations **

OK Requirements file should be up-to-date
OK You should use at least PHP 5.3.4 due to PHP bug #52083 in earlier versions
OK When using annotations you should have at least PHP 5.3.8 due to PHP bug #55156
OK You should not use PHP 5.4.0 due to the PHP bug #61453
OK When using the logout handler from the Symfony Security Component, you should have at least PHP 5.4.11 due to PHP bug #63379 (as a workaround, you can also set invalidate_session to false in the security logout handler configuration)
OK You should use PHP 5.3.18+ or PHP 5.4.8+ to always get nice error messages for fatal errors in the development environment due to PHP bug #61767/#60909
OK PCRE extension should be at least version 8.0 (8.32 installed)
OK PHP-XML module should be installed
OK mb_strlen() should be available
OK iconv() should be available
OK utf8_decode() should be available
OK posix_isatty() should be available
WARNING intl extension should be available
Install and enable the intl extension (used for validators).

WARNING a PHP accelerator should be installed
Install and enable a PHP accelerator like APC (highly recommended).

OK short_open_tag should be disabled in php.ini
OK magic_quotes_gpc should be disabled in php.ini
OK register_globals should be disabled in php.ini
OK session.auto_start should be disabled in php.ini
OK PDO should be installed
OK PDO should have some drivers installed (currently available: mysql, pgsql, sqlite)



Hopefully you guys can help!
Thanks
Corkonian
Junior Member
 
Posts: 1
Joined: Wed Oct 16, 2013 10:37 pm