This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Propel 1.2 for Symfony 2.4

Discuss installing Symfony 2 here

Propel 1.2 for Symfony 2.4

by Dekmabot » Mon Dec 09, 2013 9:29 pm

Good day Everyone!

I use new version Symfony 2.4.
I`ve made my project with Doctrine, everything is fine, but now I need to switch to Propel.

I added it t0 composer.json, installed,
added "Propel\PropelBundle\PropelBundle()" to AppKernel.php
added "Propel" and "Phing" in autoload.php

It seams to be ok, becouse I can run some propel commands in console, but on my webpage I see some strange errors:

FatalErrorException: Compile Error: Declaration of Propel\PropelBundle\Request\ParamConverter\PropelParamConverter::apply() must be compatible with Sensio\Bundle\FrameworkExtraBundle\Request\ParamConverter\ParamConverterInterface::apply(Symfony\Component\HttpFoundation\Request $request, Sensio\Bundle\FrameworkExtraBundle\Configuration\ParamConverter $configuration) in web/vendor/propel/propel-bundle/Propel/PropelBundle/Request/ParamConverter/PropelParamConverter.php line 26

Where to find a solution? It`s almost a new setup... Is it a problem of a new version?
Dekmabot
Junior Member
 
Posts: 1
Joined: Mon Dec 09, 2013 9:19 pm

Re: Propel 1.2 for Symfony 2.4

by dreamchaser » Thu Dec 12, 2013 11:18 pm

Hi,
I got the same problem. Have you resolved the problem? Can you share your solution please? Thanks.
Regards
dreamchaser
Junior Member
 
Posts: 1
Joined: Thu Dec 12, 2013 11:16 pm

Re: Propel 1.2 for Symfony 2.4

by laurentb » Sun Jan 19, 2014 7:26 pm

Hello,
Same problem for me, interested if you have solved your problem
Thanks
laurentb
Junior Member
 
Posts: 1
Joined: Sun Jan 19, 2014 7:24 pm