This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Production deploy: non-existent parameter "kernel.debug"

Discuss installing Symfony 2 here

Production deploy: non-existent parameter "kernel.debug"

by Alphanumerix » Fri Jan 31, 2014 1:33 pm

Hello there.

I have tried to deploy first project in SF2 (2.4.*), but failed. There is an error, that I can't resolve:

Code: Select all
ParameterNotFoundException: You have requested a non-existent parameter "kernel.debug".


Google can't help me at this moment, so I've figured it out, that I will ask about it here.

What I've tried:
    Clearing cache's
    Double check parameters.yml
    Change all "%kernel.debug%" in config.yml to false.
    Use config.php to check is everything ok.
    Use newest composer with install/update stuff
    Turning off Debug::enable() and setting $kernel = new AppKernel('prod', false) in app.php and app_dev.php (app_dev.php will be removed in near future)

I'm kinda out of idea's right now.

What can I say about hosting server?
    I have access to shell
    server is using php 5.2, but I have access to php54
    server is using cpanel for configuration, i've set it to use php54 in public_html folder, where app.php is right now
    i have ability to install pear/pecl packages
    ICU version used in 1.1.* (because there is intl 4.2 installed on host)
    added "symfony/intl ~2.3" to composer.json and installed it

Traces:
in /home/eq196500/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php line 106
at ParameterBag->get('kernel.debug') in /home/eq196500/app/bootstrap.php.cache line 1954
at Container->getParameter('kernel.debug') in /home/eq196500/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/FrameworkBundle.php line 85
at FrameworkBundle->build(object(ContainerBuilder)) in /home/eq196500/app/bootstrap.php.cache line 2557
at Kernel->prepareContainer(object(ContainerBuilder)) in /home/eq196500/app/bootstrap.php.cache line 2537
at Kernel->buildContainer() in /home/eq196500/app/bootstrap.php.cache line 2490
at Kernel->initializeContainer() in /home/eq196500/app/bootstrap.php.cache line 2270
at Kernel->boot() in /home/eq196500/app/bootstrap.php.cache line 2301
at Kernel->handle(object(Request)) in /home/eq196500/public_html/app_dev.php line 29


EDIT:
I've deploy project on two others hostings and it's works fine on both without any error, so I assume, that this was server-specific error.
But this is not over - I have to find out is there a way to fix it before I'll recommend change server to client.
Alphanumerix
Junior Member
 
Posts: 1
Joined: Fri Jan 31, 2014 1:00 pm

Re: Production deploy: non-existent parameter "kernel.debug"

by Maks Baum » Wed Apr 30, 2014 12:31 pm

Anyone knows the answer for that? I've got the same problem - what is interesting problem occurs on php 5.4 but when i change interpreter to php 5.3 project works fine (and i've tested fresh installation of symfony - same problem)
Maks Baum
Junior Member
 
Posts: 6
Joined: Wed Apr 30, 2014 9:35 am

Re: Production deploy: non-existent parameter "kernel.debug"

by joshcrawmer4 » Sat May 03, 2014 1:50 am

You need to change your Cache Settings. I know how to do it on Mamp but not sure on other servers. Go to preferences->Cache-> And Your options are APC, eAccelerator or xCache... Try Each one then go back to web/config.php page and refresh and continue... Try each one till you find the one that works
joshcrawmer4
Junior Member
 
Posts: 1
Joined: Sat May 03, 2014 1:44 am

Re: Production deploy: non-existent parameter "kernel.debug"

by Maks Baum » Tue May 06, 2014 9:08 am

Yeah - this may be the sollution - after a little investigation I found that this could happen when your hosting provider uses php 5.4 + eaccelerator which doesn't support anonymous function out of the box. I'm still waiting for response from my hosting provider will they fix it or not :)
Maks Baum
Junior Member
 
Posts: 6
Joined: Wed Apr 30, 2014 9:35 am

Re: Production deploy: non-existent parameter "kernel.debug"

by mehdiraddadi » Wed May 07, 2014 4:21 pm

I have a question how Change all "%kernel.debug%" in config.yml to false.
and any solution for this error ParameterNotFoundException: You have requested a non-existent parameter "kernel.debug".
mehdiraddadi
Junior Member
 
Posts: 1
Joined: Wed May 07, 2014 3:59 pm