This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Problem with work right after installing

Discuss installing Symfony 2 here

Problem with work right after installing

by izmerov_dmitry » Tue Apr 01, 2014 12:25 pm

I have several problems after that when I put downloaded archive in folder in localhost, my settings: OS - Win7, PHP 5.5, Mysql 5.5, Apache 2.4.7.

Answer from app/check.php -

D:\OpenServer\domains\localhost\Symfony>php app/check.php
********************************
* *
* Symfony requirements check *
* *
********************************

* Configuration file used by PHP: D:\OpenServer\userdata\temp\config\php.ini

** ATTENTION **
* The PHP CLI can use a different php.ini file
* than the one used with your web server.
* (especially on the Windows platform)
* To be on the safe side, please also launch the requirements check
* from your web server using the web/config.php script.

** Mandatory requirements **

OK PHP version must be at least 5.3.3 (5.5.6 installed)
OK PHP version must not be 5.3.16 as Symfony won't work properly with it
OK Vendor libraries must be installed
OK app/cache/ directory must be writable
OK app/logs/ directory must be writable
OK date.timezone setting must be set
OK Configured default timezone "Europe/Moscow" must be supported by your
installation of PHP
OK json_encode() must be available
OK session_start() must be available
OK ctype_alpha() must be available
OK token_get_all() must be available
OK simplexml_import_dom() must be available
OK APC version must be at least 3.1.13 when using PHP 5.4
OK detect_unicode must be disabled in php.ini
OK xdebug.show_exception_trace must be disabled in php.ini
OK xdebug.scream must be disabled in php.ini
OK PCRE extension must be available

** Optional recommendations **

OK xdebug.max_nesting_level should be above 100 in php.ini
OK Requirements file should be up-to-date
OK You should use at least PHP 5.3.4 due to PHP bug #52083 in earlier ver
sions
OK When using annotations you should have at least PHP 5.3.8 due to PHP b
ug #55156
OK You should not use PHP 5.4.0 due to the PHP bug #61453
OK When using the logout handler from the Symfony Security Component, you
should have at least PHP 5.4.11 due to PHP bug #63379 (as a workaround, you can
also set invalidate_session to false in the security logout handler configurati
on)
OK You should use PHP 5.3.18+ or PHP 5.4.8+ to always get nice error mess
ages for fatal errors in the development environment due to PHP bug #61767/#6090
9
OK PCRE extension should be at least version 8.0 (8.32 installed)
OK PHP-XML module should be installed
OK mb_strlen() should be available
OK iconv() should be available
OK utf8_decode() should be available
OK intl extension should be available
OK intl extension should be correctly configured
OK intl ICU version should be at least 4+
OK a PHP accelerator should be installed
OK short_open_tag should be disabled in php.ini
OK magic_quotes_gpc should be disabled in php.ini
OK register_globals should be disabled in php.ini
OK session.auto_start should be disabled in php.ini
OK PDO should be installed
OK PDO should have some drivers installed (currently available: mysql, pg
sql, sqlite)

First problem - I don't have access to ..Symfony/web/app.php.

Second problem - that first problem is resolved temporarily - I turn off .htaccess and
I got antoher one - see picture lower
Image

It's so shock for starting with Symfony2, I need help with these problems.
izmerov_dmitry
Junior Member
 
Posts: 1
Joined: Tue Apr 01, 2014 11:52 am