This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

problems installing symfony

Discuss installing Symfony 2 here

problems installing symfony

by ayahuasca » Thu Apr 17, 2014 9:18 am

Hello,

I am new to symfony and wanted to try it to see if I like it.
I am trying to install symfony using this page: http://symfony.com/doc/current/book/installation.html

I am using Option 1) Composer
at one point it is saying: go to http://localhost/config.php. I am installing this on a remote development server to I go to the corresponding URL
and get the following message: RuntimeException: Unable to create the cache directory (/path/to/installation/directory/symfony/app/cache/prod)
So i followed the 'Setting up Permissions'
I get the error: chmod: invalid mode: `+a'
so I do step 2 of setting up permissions.
This seems to work and i go to the correct url again. And get the following message again:
RuntimeException: Unable to create the cache directory
After step 3 of setting up permissions i still get this message.

I even 'chmod -R 777' the app/logs directory and the app/cache directory and i still get this message.

Option 4 of the 'setting up permissions' is no option for me because i log in using root user.

What could I do next?
ayahuasca
Junior Member
 
Posts: 1
Joined: Thu Apr 17, 2014 8:59 am

Re: problems installing symfony

by Maks Baum » Fri May 02, 2014 2:14 pm

Works even on shared hosting :)
1. chmod 777 on logs and cache
2. app / app_dev & console - be sure to use umask(0000)
Maks Baum
Junior Member
 
Posts: 6
Joined: Wed Apr 30, 2014 9:35 am

Re: problems installing symfony

by hello_kitty » Fri May 09, 2014 10:01 am

I had the same problem. Thanks for sharing solution. It's so simple :)
hello_kitty
Junior Member
 
Posts: 3
Joined: Fri May 09, 2014 9:47 am