This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

transfer of a local site to a shared hosting

Discuss installing Symfony 2 here

transfer of a local site to a shared hosting

by meaulnes » Wed Apr 23, 2014 5:47 pm

Hi,
Symfony is a great framework. I could manage to create a local bilingual site in a few days on my local computer. Now I would like to see how all this run on a remote server.
I use a shared hosting and have no access to the root shell on the server.
I uploaded the database and the files on the document root of the server
and I have this tree: document root -- Symfony -- web (app, bin, etc.)

I changed the parameters for the database base and after allowing my IP I can access mydomain/Symfony/web/config.php. It seems that I have no big trouble only two recommmandations:

To enhance your Symfony experience, it’s recommended that you fix the following:

Install and enable a PHP accelerator like APC (highly recommended).
Set short_open_tag to off in php.ini*.

As I cannot access php.ini I let thing as they are.

When I click on Configure you Symfony application on line I get the following message

ContextErrorException: Warning: is_readable(): open_basedir restriction in effect. File(/var/www/Symfony/src/Blogger/BlogBundle/Resources/views/layout.html.twig) is not within the allowed path(s): (/htdocs:/var/www/zoraldia.com/htdocs:/var/www/zoraldia.com/tmp:/var/www/zoraldia.com/exec_dir:/var/www/zoraldia.com/php-session:/var/lib/lws/:/usr/base/var/lib/lws:/htdocs:/tmp:/exec_dir:/php-session:/usr/share/php) in /htdocs/Symfony/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Templating/Loader/FilesystemLoader.php line 61


I cannot change open_basedir as I cannot access php.ini. Is there any workaround or should I admit that my Symfony site cannot run on this hosting ?
The other page of my site are completely blank.
meaulnes
Junior Member
 
Posts: 8
Joined: Sun Apr 06, 2014 8:40 am