This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

NotFoundHttpException: No route found for "GET /"

Discuss installing Symfony 2 here

NotFoundHttpException: No route found for "GET /"

by Kue » Thu Jun 05, 2014 12:29 pm

Hi all,
my first steps with Symfony.

I am following the quick tour http://symfony.com/doc/current/quick_tour/the_big_picture.html, so I have installed composer, and then symfony2, I have created myproject folder, done chek.php, started the server via php app/console server:run ....no problems.

Anyway when I try to open localhost:8000 i don't get the welcome page but this:

No route found for "GET /"
404 Not Found - NotFoundHttpException
1 linked Exception:

ResourceNotFoundException ยป



Can you help me?
Thank you in advance!

PHP Version 5.5.9
OS: Ubuntu
Kue
Junior Member
 
Posts: 2
Joined: Thu Jun 05, 2014 12:15 pm

Re: NotFoundHttpException: No route found for "GET /"

by Kue » Fri Jun 06, 2014 2:32 pm

Solved!
I have cancelled the project and reinstalled Symfony: everything works now. Probably something went wrong during the first installation.

Thank you anyway!
Kue
Junior Member
 
Posts: 2
Joined: Thu Jun 05, 2014 12:15 pm

Re: NotFoundHttpException: No route found for "GET /"

by MGuerrillas » Mon Jun 09, 2014 12:05 pm

I'm following the guide too and I'm getting exactly the same error at the same point.

Is there some problem with the sample code that's downloaded?

Not a very encouraging introduction to Symfony.
MGuerrillas
Junior Member
 
Posts: 2
Joined: Mon Jun 09, 2014 12:01 pm

Re: NotFoundHttpException: No route found for "GET /"

by MGuerrillas » Wed Jun 11, 2014 10:01 am

Kue wrote:Solved!
I have cancelled the project and reinstalled Symfony: everything works now. Probably something went wrong during the first installation.

Thank you anyway!


Same for me. Whatever the problem was has been fixed. I reinstalled it today and everything works as it should.
MGuerrillas
Junior Member
 
Posts: 2
Joined: Mon Jun 09, 2014 12:01 pm

Re: NotFoundHttpException: No route found for "GET /"

by narven » Wed Jun 11, 2014 7:15 pm

MGuerrillas are you running 2.5 version?
What OS?
User avatar
narven
Junior Member
 
Posts: 10
Joined: Fri Nov 06, 2009 11:42 pm
Location: London, UK