This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Php.ini and Installation of Symphony/

Discuss installing Symfony 2 here

Php.ini and Installation of Symphony/

by Swimmer » Sun Sep 07, 2014 1:29 am

Hi, I'm totally new here. It's nice to have a forum for Symfony. I'm a Microsoft (and before) database guy from way back, but not really a UNIX guy, maybe that explains my lack of understanding. I'm trying to install Symfony.
I'm using a Macbook Pro with MAMP installed. I'm trying to run instructions from The Symfony Book 2.5 documentation. It say there at two ways to install. Using the first way, it says the following:

Start by downloading Composer3 anywhere onto your local computer. If you have curl installed, it's as
easy as: $ curl -s https://getcomposer.org/installer | php


I open terminal and type in the command, and get the following:

#!/usr/bin/env php
Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:

The detect_unicode setting must be disabled.
Add the following to the end of your `php.ini`:
detect_unicode = Off

A php.ini file does not exist. You will have to create one.
If you can not modify the ini file, you can also run `php -d option=value` to modify ini values on the fly. You can use -d multiple times.


From MAMP: Using phpInfo I Get:
Configuration File (php.ini) Path /Applications/MAMP/bin/php/php5.3.6/conf
Loaded Configuration File: /Applications/MAMP/bin/php/php5.3.6/conf/php.ini


I've modified the php.ini shown via phpInfo and MAMP , restarted the server, etc. but the installation keeps giving me the same message. I thought that maybe I'm working on a different php (via terminal) than the one with which MAMP is working. I went back and ran: php --ini and received the following:

Configuration File (php.ini) Path: /etc
Loaded Configuration File: (none)
Scan for additional .ini files in: (none)
Additional .ini files parsed: (none)


Please help with diagnostics and fix? Thanks in advance.
Swimmer
Junior Member
 
Posts: 1
Joined: Sun Sep 07, 2014 12:59 am

Re: Php.ini and Installation of Symfony

by apulmca2k4 » Sat Sep 13, 2014 2:29 pm

There are multiple php installation on that system that is why are you facing this issue.

You should try

>> php -c="/Applications/MAMP/bin/php/php5.3.6/conf/php.ini"

instead of

>> php

Try it & then post the result here.
User avatar
apulmca2k4
Senior Member
 
Posts: 152
Joined: Mon Aug 04, 2008 6:57 am
Location: New Delhi, India