This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

[SOLVED] Production deployment issues

Discuss installing Symfony 2 here

[SOLVED] Production deployment issues

by Veleous » Sun Mar 01, 2015 3:45 am

Hi,

I am trying to get Symfony to work without using the built in PHP server, however, I always get 403 when trying to access it via my virtual host address. My virtual host conf file looks like this:

Code: Select all
<VirtualHost *:80>
        ServerName www.symfony2.local
        ServerAlias symfony2.local
        DocumentRoot /var/www/vhosts/symfony2.local/web

        <Directory /var/www/vhosts/symfony2.local/web>
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>

        ErrorLog /var/log/httpd/symfony2-error.log
        CustomLog /var/log/httpd/symfony2-access.log combined
</VirtualHost>


My hosts file looks like this:

Code: Select all
127.0.0.1 symfony2.local


The .htaccess in web/ is the default Synfony2 installed file.

Whenever I try to access http://synfony2.local I get the following error in my log file:

Code: Select all
(13)Permission denied: [client 127.0.0.1:32858] AH00529: /var/www/vhosts/symfony2.local/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/var/www/vhosts/symfony2.local/web/' is executable


Code: Select all
-rwxr-xr-x. 1 apache apache 2.8K Mar  1 00:48 .htaccess
drwxr-xr-x.  3 apache apache 4.0K Mar  1 01:24 web


Can someone please point out what I am missing here?

Many thanks.

[SOLVED]
Turns out SeLinux was being a bawbag. Once I disabled SeLinux everything worked fine.
Veleous
Junior Member
 
Posts: 1
Joined: Sun Mar 01, 2015 3:30 am