This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Symfony exception (after setting magic_quotes_gpc to Off)

Installation and environment issues, mainly on 1.x but there's some 2.x here too.

Symfony exception (after setting magic_quotes_gpc to Off)

by kristeta126 » Fri Nov 18, 2005 3:38 am

Hi!

I was following the project creation steps. I reached the part that says:

Check that everything still works fine by requesting:

http://localhost/myapp_dev.php/


and I get this message.


[exception] sfInitializationException [message] Configuration file "/var/symproject/myapp/config/php.yml" specifies that php.ini "magic_quotes_gpc" key must be set to "" [code] N/A [class] sfPhpConfigHandler [file] /usr/local/lib/php/symfony/symfony/config/sfPhpConfigHandler .class.php [line] 98 [symfony] v. 1.0.0-DEV (symfony-project.org) [PHP] v. 5.0.5 [stack trace] at sfConfigCache::execute() in [/usr/local/lib/php/symfony/symfony/config/sfConfigCache.cla ss.php:66] at sfConfigCache::callHandler() in [/usr/local/lib/php/symfony/symfony/config/sfConfigCache.cla ss.php:150] at sfConfigCache::checkConfig() in [/usr/local/lib/php/symfony/symfony/config/sfConfigCache.cla ss.php:202] at import() in [/usr/local/lib/php/symfony/symfony/symfony.php:122] at require_once() in [/var/symproject/myapp/config/config.php:47] at require_once() in [/var/symproject/web/myapp_dev.php:8]


I tried to set magic_quotes_gpc to Off (since symfony likes it Off). I have my php.yml (in /var/symproject/myapp/config/) as:


set:
magic_quotes_runtime: off
log_errors: on
arg_separator.output: \&

check:
magic_quotes_gpc: off
register_globals: off


Please help. I don't know what to do next.

Thanks!
kristeta126
Junior Member
 
Posts: 24
Joined: Wed Nov 09, 2005 3:04 am
Location: QC

Re: Symfony exception (after setting magic_quotes_gpc to Off)

by spascoe » Fri Nov 18, 2005 5:18 am

I suspect, that you have found a problem similar to one that I encountered.

Probably, you are not using the php.ini file that you think you are using. The sfPhpConfigHandler.class.php has been updated in the repository to include the path to the php.ini file that is currently in use.

If you can't upgrade to that version, you might try searching for php.ini files in other locations than where you expect them.

I am using xampp 1.5.0 on windows and found that there was a php.ini in the xampp\apache\bin folder and apache used it instead of the one in xampp\php folder that I expected. (Don't forget to restart apache after you change the php.ini.)

Hope this helps,
Scott
spascoe
Member
 
Posts: 52
Joined: Sat Nov 12, 2005 7:50 am
Location: Indianapolis

Re: Symfony exception (after setting magic_quotes_gpc to Off)

by RoVeRT » Fri Nov 18, 2005 5:24 am

If you dont want to update you can just create a file with
Code: Select all
<?php phpinfo(INFO_GENERAL);
and it will display PHP config info and php.ini location
RoVeRT
Senior Member
 
Posts: 146
Joined: Thu Oct 27, 2005 8:56 pm

Re: Symfony exception (after setting magic_quotes_gpc to Off)

by kristeta126 » Fri Nov 18, 2005 7:48 am

Thank you! Thank you so much! It helped a lot!

Now, my screen displays this:


Congratulations!

If you see this page, it means that the creation of your symfony project on this system was successful.

You can now create your model and customize default templates.

© 2004-2005 symfony project


:D~ :-D~ :grin:
kristeta126
Junior Member
 
Posts: 24
Joined: Wed Nov 09, 2005 3:04 am
Location: QC