This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Starting a localhost on windows install

Installation and environment issues, mainly on 1.x but there's some 2.x here too.

Starting a localhost on windows install

by petesmith » Wed Nov 30, 2005 12:42 am

Hello

I am trying to get this working, apache 2 on windows php 5.

I did the pear install, made

D:\Applications\Apache Group\Apache2\htdocs\myproject

ran the symfony command for make project and app, then in my http conf file:

<VirtualHost *:80>
ServerName myapp.localhost
DocumentRoot "D:\Applications\Apache Group\Apache2\htdocs\myproject\web"
DirectoryIndex index.php
Alias /sf /$data_dir/myproject/web/sf

<Directory "D:\Applications\Apache Group\Apache2\htdocs\myproject\web">
AllowOverride All
</Directory>
</VirtualHost>
but I get nothing at

http://myapp.localhost/index.php/

any idea?
petesmith
Junior Member
 
Posts: 4
Joined: Wed Nov 30, 2005 12:39 am

Re: Starting a localhost on windows install

by Ian » Wed Nov 30, 2005 5:01 am

edit your hosts file (c:\windows\system32\drivers\etc\hosts) and add the line:

Code: Select all
127.0.0.1    myapp.localhost


Then restart your browser and try again.
Ian

Join us on IRC for LIVE support!
Report bugs here.
Ian
Faithful Member
 
Posts: 386
Joined: Tue Oct 25, 2005 6:53 pm
Location: Boulder, CO (USA)

Re: Starting a localhost on windows install

by petesmith » Wed Nov 30, 2005 5:25 pm

That worked great, but now I get

sfInitializationException
message: sfAction initialization failed for module "default", action "web"
code: N/A
class: N/A
file: D:\Applications\Apache Group\Apache2\htdocs\myproject\cache\myapp\prod\config\confi g_core_compile.yml.php
line: 296


any clue?
petesmith
Junior Member
 
Posts: 4
Joined: Wed Nov 30, 2005 12:39 am

Re: Starting a localhost on windows install

by Ian » Wed Nov 30, 2005 8:13 pm

Not sure why you're getting that. Make sure you've upgraded to the latest beta version and make sure you clear your cache (symfony cc).

I don't use windows, so I'm not sure of what might be wrong.

One tip though, you might want to rename that $data_dir to c:\path\to\pear\data as $data_dir doesn't mean anything in the httpd.conf. :)~ :-)~ :smile:
Ian

Join us on IRC for LIVE support!
Report bugs here.
Ian
Faithful Member
 
Posts: 386
Joined: Tue Oct 25, 2005 6:53 pm
Location: Boulder, CO (USA)

Re: Starting a localhost on windows install

by petesmith » Wed Nov 30, 2005 10:08 pm

Upgrading to beta worked fine, and fixed my prob. Nice job with the pear installer.
petesmith
Junior Member
 
Posts: 4
Joined: Wed Nov 30, 2005 12:39 am

Re: Starting a localhost on windows install

by synace » Sat Dec 03, 2005 10:32 am

I'm working on my laptop..

for symfony, I'm running:

Symfony 0.4.3

Windows XP
Posadis 0.60.6
Apache 2.0.54
MySQL 4.1.13a-nt
PHP 5.0.4
SubVersion 1.2.3
TortoiseSVN 1.2.6

Additional Pear Packages:
PACKAGE VERSION STATE
Archive_Tar 1.3.1 stable
Benchmark 1.2.4 stable
Console_Getopt 1.2 stable
Console_Table 1.0.2 stable
DB 1.7.6 stable
HTML_Template_IT 1.1.3 stable
Log 1.9.2 stable
Mail 1.1.9 stable
Net_SMTP 1.2.7 stable
Net_Socket 1.0.6 stable
Net_UserAgent_Detect 2.1.0 stable
PEAR 1.4.5 stable
PEAR_Frontend_Gtk 0.4.0 beta
PEAR_PackageFileManager 1.5.2 stable
PHPUnit 1.3.2 stable
PHPUnit2 2.3.3 stable
PHP_CompatInfo 1.0.0 stable
PhpDocumentor 1.2.3 stable
VersionControl_SVN 0.3.0alpha1 alpha
XML_Parser 1.2.7 stable
XML_RPC 1.4.4 stable
XML_Tree 1.1 stable
phing 2.1.1 stable


I have an already compiled mysql.so for symfony if anyone needs it. Though, I imagine I could have used the built-in ODBC support? Also, if anyone has a pre-compiled mmcache.dll for my php version that would be cool! (I don't have visual studio).

If you have any questions about getting up and running on windows, feel free to ask.
~synace~
M2Synergies, Inc.
http://m2synergies.com
synace
Junior Member
 
Posts: 24
Joined: Sat Dec 03, 2005 10:03 am