This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Apache crashes (Symfony 1.4)

Installation and environment issues, mainly on 1.x but there's some 2.x here too.

Apache crashes (Symfony 1.4)

by dricho » Tue Mar 27, 2012 11:18 am

Hello! I'm new to this forum and a newbie in Symfony so please bear with me. Thanks!

Ok, to the problem.. First of all my system is set-up like this:

In Windows 7 (Service Pack 1),
I installed Apache 2.2 (httpd-2.2.22-win32-x86-openssl-0.9.8t.msi),
then I installed PHP (php-5.3.10-Win32-VC9-x86.msi).

I run some tests and there are no problems. The Apache server is running and I can run some PHP scripts.

Then I install Symfony 1.4, followed each step, created the projects.. etc. BUT when I was about to look at the index.php in the web folder, nothing happens and Mozilla Firefox 9.0.1 reports this, "The connection was reset. The connection to the server was reset while the page was loading." (There are no other notifications of crashes in Apache, and Apache is still running). So, I make some PHP files again and still working but not those .php Symfony 1.4 files.

I decided to test this on my Windows XP machine using the same Apache and PHP packages, and the results are still the same. One thing though is different which I also think where the problem is coming from, a notification by Windows said that Apache HTTP Server crashed (the window with "Send error report, don't send" came up). But after that, the Apache server is still running fine and I still can run PHP sample programs.

Pelase help me! I also tried using the Symfony 1.4 sandbox but has still the same results. So there maybe something with Apache. Hmm, may I know also the best version of PHP and Apache that can work with Symfony 1.4? And if possible, can you walk me through the best way in installing Apache. Maybe there are some configurations that I overlooked. But I promised that I follw every step in the Symfony getting started guide.

Thank you very much! :)
dricho
Junior Member
 
Posts: 1
Joined: Tue Mar 27, 2012 10:45 am

Re: Apache crashes (Symfony 1.4)

by danielh » Fri May 04, 2012 5:17 pm

I've been developing with symfony on Windows 7 for a couple of years and have encountered the problem you're referring to many times. In the end I finally found a combination of Apache + PHP which work well together: Apache 2.2.11 and PHP 5.3.10 . I didn't install them through the MSIs though so im not sure which installation files you should use.

One cause of these problems for me was APC if you're running that PHP extension. My current setup works fine with it but previous setups didn't until i disabled it.

One other setup i had gave me the problem because i didn't have a setting for "date.timezone" in my php.ini file - try giving that a value if it doesn't currently have one

Sorry, I can't be of much more help, I know how frustrating this problem is!
danielh
Member
 
Posts: 49
Joined: Tue Dec 11, 2007 6:09 am
Location: Australia

Re: Apache crashes (Symfony 1.4)

by dlamichhane » Mon May 14, 2012 9:32 pm

You degrade you php version for wamp, xampp. You will resolve you problem. I had also the same problem. I degrade my php version to 5.3.1 and it worked fine
dlamichhane
Junior Member
 
Posts: 1
Joined: Mon May 14, 2012 9:29 pm

Re: Apache crashes (Symfony 1.4)

by sree333_d » Sat May 19, 2012 6:54 am

i'm working on a windows XP machine, with the latest xampp php5.2.8, apache 2.2.x perl and other stuff... don't need to download pear because it was previously installed on xampp..

i've downloaded symfony through pear and downloaded without any troubles.

i've started to build the "My first symfony project" tutorial.. had some troubles but fixed reading the forum
i had to change this line:

$ php symfony configure:database mysql://root:pa$$word@localhost/symfony_project

for this one :

php symfony configure:database "mysql:host=localhost;dbname=symfony_project" root pa$$word

because with the first line i was getting troubles with the database selection, it shows some errors that the database was not selected.

to this far everythings ok...
after the filling of the database
and generating the forms and modules

i wanted to check as the tutorial says the page: http://localhost/sf_sandbox/web/frontend_dev.php/post , in my case http://viking/frontend_dev.php/post because i'm running it on a virtualhost

i got a warning asking me to check frontend_dev.php ... i commented the lines
if (!in_array(@$_SERVER['REMOTE_ADDR'], array('127.0.0.1', '::1')))
{
die('You are not allowed to access this file. Check '.basename(__FILE__).' for more information.');
}

to se the pages... and the troubles began

if i try to access http://viking/frontend_dev.php/post apache crash... i have to shutdown the apache from xampp control panel.. and then start apache again...

if i try to access http://viking/frontend_dev.php
it shows a page that indicates me to define a homepage route in my routing.yml

but with /comment or /post after frontend_dev.php apache just crash.. and i have to restart the service.

i'm new to symfony but not new with php... if anyone had this problem please tell me how to fix it.

thanks
sree333_d
Junior Member
 
Posts: 1
Joined: Sat May 19, 2012 6:51 am