This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Autoloading of class "PostPeer" failed

Installation and environment issues, mainly on 1.x but there's some 2.x here too.

Autoloading of class "PostPeer" failed

by treerunner » Mon Nov 14, 2005 7:00 am

hi,

going through the first install tutorial and am hitting a wall. doing everything as stated except am using pgsql so changed a few things..

all works fine until i get build the scaffold..

when i go to the post page i get:

[exception] sfAutoloadException [message] Autoloading of class "PostPeer" failed [code] N/A [class] N/A [file] /opt/local/apache2/htdocs/stest/cache/testapp/prod/config/co nfig_bootstrap_compile.yml.php [line] 1706 [symfony] v. 1.0.0-DEV (symfony-project.org) [PHP] v. 5.0.5 [stack trace] at actions::__autoload() in [/opt/local/apache2/htdocs/stest/testapp/modules/post/action s/actions.class.php:13] at executeList() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:299] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:939] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:1048] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:677] at forward() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:93] at actions::forward() in [/opt/local/apache2/htdocs/stest/testapp/modules/post/action s/actions.class.php:8] at executeIndex() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:299] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:939] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:1048] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:677] at forward() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:2209] at dispatch() in [/opt/local/apache2/htdocs/stest/web/index.php:10]

and the comments page:

[exception] sfAutoloadException [message] Autoloading of class "CommentPeer" failed [code] N/A [class] N/A [file] /opt/local/apache2/htdocs/stest/cache/testapp/prod/config/co nfig_bootstrap_compile.yml.php [line] 1706 [symfony] v. 1.0.0-DEV (symfony-project.org) [PHP] v. 5.0.5 [stack trace] at actions::__autoload() in [/opt/local/apache2/htdocs/stest/testapp/modules/comment/act ions/actions.class.php:13] at executeList() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:299] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:939] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:1048] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:677] at forward() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:93] at actions::forward() in [/opt/local/apache2/htdocs/stest/testapp/modules/comment/act ions/actions.class.php:8] at executeIndex() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:299] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:939] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:1048] at execute() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:677] at forward() in [/opt/local/apache2/htdocs/stest/cache/testapp/prod/config/c onfig_core_compile.yml.php:2209] at dispatch() in [/opt/local/apache2/htdocs/stest/web/index.php:10]

i have made changes to orm.yml:

all:
adapter: PostgreSQL
host: localhost
database: symfonytest
username: me
password: blabla

and to propel.ini:

propel.targetPackage = model
propel.project = stest
propel.database = pgsql
propel.database.createUrl = pgsql://localhost/
propel.database.url = pgsql://localhost/symfonytest

am i missing something? any ideas? any help would be much appreciated...

thanks!
treerunner
Junior Member
 
Posts: 2
Joined: Mon Nov 14, 2005 6:44 am

Re: Autoloading of class "PostPeer" failed

by RoVeRT » Mon Nov 14, 2005 3:13 pm

The first problem that I see is in orm.yml adapter should be pgsql and not PostgreSQL.
RoVeRT
Senior Member
 
Posts: 146
Joined: Thu Oct 27, 2005 8:56 pm

Re: Autoloading of class "PostPeer" failed

by treerunner » Mon Nov 14, 2005 4:54 pm

bingo - it worked, thanks.

i think i may have been led astray by this page:

http://www.symfony-project.com/content/book/page/model.html

Under configuration it says the value for the adapter parameter should be PostgreSQL, not pgsql. might be a good idea to change that..

other than that, great project, i look forward to working with it!
treerunner
Junior Member
 
Posts: 2
Joined: Mon Nov 14, 2005 6:44 am

Re: Autoloading of class "PostPeer" failed

by francois » Tue Nov 15, 2005 12:30 pm

treerunner,

You're right, the doc was wrong. It is now fixed.
francois
Faithful Member
 
Posts: 1638
Joined: Sat Oct 22, 2005 4:56 pm

Re: Autoloading of class "PostPeer" failed

by kristeta126 » Tue Dec 06, 2005 6:10 am

I am also having the same problem as treerunner. Here is what I am getting:


sfAutoloadException
message: Autoloading of class "CommentPeer" failed
code: N/A
class: N/A
file: /var/symfony-projects/cache/TACISApp/prod/config/config_boot strap_compile.yml.php
line: 1587
stack trace
at actions::__autoload() in [/var/symfony-projects/TACISApp/modules/comment/actions/acti ons.class.php:24]
at executeList() in [/var/symfony-projects/cache/TACISApp/prod/config/config_cor e_compile.yml.php:359]
at execute() in [/var/symfony-projects/cache/TACISApp/prod/config/config_cor e_compile.yml.php:1032]
at execute() in [/var/symfony-projects/cache/TACISApp/prod/config/config_cor e_compile.yml.php:1142]
at execute() in [/var/symfony-projects/cache/TACISApp/prod/config/config_cor e_compile.yml.php:764]
at forward() in [/var/symfony-projects/cache/TACISApp/prod/config/config_cor e_compile.yml.php:121]
at actions::forward() in [/var/symfony-projects/TACISApp/modules/comment/actions/acti ons.class.php:19]
at executeIndex() in [/var/symfony-projects/cache/TACISApp/prod/config/config_cor e_compile.yml.php:359]
at execute() in [/var/symfony-projects/cache/TACISApp/prod/config/config_cor e_compile.yml.php:1032]
at execute() in [/var/symfony-projects/cache/TACISApp/prod/config/config_cor e_compile.yml.php:1142]
at execute() in [/var/symfony-projects/cache/TACISApp/prod/config/config_cor e_compile.yml.php:764]
at forward() in [/var/symfony-projects/cache/TACISApp/prod/config/config_cor e_compile.yml.php:2267]
at dispatch() in [/var/symfony-projects/web/index.php:10]
info
symfony v. 1.0.0-DEV
PHP v. 5.1.1
for help resolving this issue, please visit www.symfony-project.com


My orm.yml is as follows:

all:
adapter: mysql
host: localhost
database: weblog
username: uname
password: somepassword


and my propel.ini is as follows:

propel.targetPackage = model
propel.project = symfony-projects
propel.database = mysql
propel.database.createUrl = mysql://localhost/
propel.database.url = mysql://uname:somepassword@localhost/weblog


Any suggestions? What should I do?

Thanks!
kristeta126
Junior Member
 
Posts: 24
Joined: Wed Nov 09, 2005 3:04 am
Location: QC

Re: Autoloading of class "PostPeer" failed

by francois » Tue Dec 06, 2005 11:19 am

did you try to clear the cache?
Code: Select all
$ symfony cc
francois
Faithful Member
 
Posts: 1638
Joined: Sat Oct 22, 2005 4:56 pm

Re: Autoloading of class "PostPeer" failed

by kristeta126 » Wed Dec 07, 2005 3:29 am

I have already cleared the cache. Now, I don't get any error messages, but I don't see anything on the browser. :cry:

What could be wrong?
kristeta126
Junior Member
 
Posts: 24
Joined: Wed Nov 09, 2005 3:04 am
Location: QC

Re: Autoloading of class "PostPeer" failed

by kristeta126 » Wed Dec 07, 2005 4:58 am

I have already resolved all the problems in my application. :D~ :-D~ :grin: Thanks to everyone who helped.

Symfony rocks! :D~ :-D~ :grin:
kristeta126
Junior Member
 
Posts: 24
Joined: Wed Nov 09, 2005 3:04 am
Location: QC