This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Failed to write cache file

Installation and environment issues, mainly on 1.x but there's some 2.x here too.

Failed to write cache file

by stuartbrown » Tue Jun 17, 2014 9:11 pm

Hi,

I'm a newb with Symfony and am following a tutorial to try and get up and running. I am running Ubuntu Server via VMWare Fusion on a Mac.

I have everything set up ok but am getting an error message when I try to visit my new site.
RuntimeException: Failed to write cache file "/var/www/html/learnsymfony/app/../var/cache/dev/classes.php".
in /var/www/html/learnsymfony/vendor/symfony/symfony/src/Symfony/Component/ClassLoader/ClassCollectionLoader.php line 239
at ClassCollectionLoader::writeCacheFile('/var/www/html/learnsymfony/app/../var/cache/dev/classes.php',

etc etc.

I'm trying to clear this up with the Setting up Permission section of http://symfony.com/doc/current/book/installation.html - Using ACL on a system that does not support chmod +a. However nothing changes for me.

I know that my web server user is www-data and when I run ls -la in the /apps directory it shows like (i've removed some of the listings):

-rw-r--r-- 1 stuartbrown stuartbrown 91899 Jun 17 11:31 bootstrap.php.cache
drwxr-xr-x+ 3 stuartbrown stuartbrown 4096 Jun 17 11:39 cache
-rw-rw-r-- 1 stuartbrown stuartbrown 1794 Jun 17 03:30 check.php
drwxr-xr-x+ 2 stuartbrown stuartbrown 4096 Jun 17 11:31 logs

should the users shown above actually be www-data? I've also tried the umask option under Without using ACL but still no joy. It's take me ages to get this far -any help trying to solve this now I'm so close would be much appreciated!
stuartbrown
Junior Member
 
Posts: 2
Joined: Tue Jun 17, 2014 8:59 pm