This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Can I use Askeet demo with Symphony 1.2.1?

Discussion around this tutorial for symfony 1.0.x

Can I use Askeet demo with Symphony 1.2.1?

by mannerv » Sun Dec 14, 2008 4:43 pm

Hello all

I am planning on making a site that is extremely similar to the Askeet demo project so I thought that I will use it as my platform. I have never done a production site with PHP, but have done a live site in the recent months with ASP.NET 2.0.

I noticed that the Askeet demo is from 2005. Since those days, Symfony framework has evolved from 1.0 to 1.2.1, if I understood correctly.

As I am trying to make an actual production site, how do you recommend I should start? Is there a version of Askeet for 1.2.1?

Is there any realism in me trying to follow the instructions for 1.0 and "adapt" them for 1.2.1? Is there some risk at putting up the 1.0 site?

I thought I would get the expert opinion before I bang my head into the wall for too really. I greatly appreciate any input and tips you can give me.
mannerv
Junior Member
 
Posts: 7
Joined: Sun Dec 14, 2008 4:12 pm

Re: Can I use Askeet demo with Symphony 1.2.1?

by mannerv » Sun Dec 14, 2008 10:19 pm

I have been doing some checking and have two extra questions. I am planning on buying an iMac to do the development on. I am hoping that OS X would give me a simple unix-like environment to get me up and running fast. Linux learning curve is too much for me to bear and Windows and XAMPP have been disappointing in the past.

Also, I am hoping to integrate reCAPTCHA into the Askeet demo.

Any comments to these? Is the Askeet project still in active development? It seems there have been no changes in ages.
mannerv
Junior Member
 
Posts: 7
Joined: Sun Dec 14, 2008 4:12 pm

Re: Can I use Askeet demo with Symphony 1.2.1?

by zvince » Sun Dec 14, 2008 11:37 pm

I met a little problem with askeet running on a 1.2 version.
Day 2 : build the data model, then generate a module to test it.
But when running version 1.2, you have to do "symfony propel:build-forms" before "symfony propel:generate-crud ..." or you get an error because the form classes are not here.
symfony propel:build-forms did not exist in v 1.0, so I suppose that there might be a lot of similar issues between v 1.0 and v 1.2.
So if you want to do the askeet tutorial, run Symfony v 1.0, otherwise do the new jobeet tutorial.
zvince
Junior Member
 
Posts: 6
Joined: Sat Dec 13, 2008 4:05 pm
Location: France

Re: Can I use Askeet demo with Symphony 1.2.1?

by mannerv » Mon Dec 15, 2008 12:11 am

zvince wrote: I met a little problem with askeet running on a 1.2 version.
Day 2 : build the data model, then generate a module to test it.
But when running version 1.2, you have to do "symfony propel:build-forms" before "symfony propel:generate-crud ..." or you get an error because the form classes are not here.
symfony propel:build-forms did not exist in v 1.0, so I suppose that there might be a lot of similar issues between v 1.0 and v 1.2.
So if you want to do the askeet tutorial, run Symfony v 1.0, otherwise do the new jobeet tutorial.

Thanks, you already saved me a lot of trouble.

So, apparently, Askeet has not been upgraded since 2005...
mannerv
Junior Member
 
Posts: 7
Joined: Sun Dec 14, 2008 4:12 pm

Re: Can I use Askeet demo with Symphony 1.2.1?

by mannerv » Mon Dec 15, 2008 12:21 am

When I go to http://www.symfony-project.org/askeet/ it says that:

"The Askeet Tutorial" is not yet available in English for the symfony 1.2.

Does this mean that the Askeet tutorial is available in some language other than English for 1.2?
mannerv
Junior Member
 
Posts: 7
Joined: Sun Dec 14, 2008 4:12 pm

Re: Can I use Askeet demo with Symphony 1.2.1?

by rschumacher » Mon Dec 15, 2008 12:32 am

mannerv wrote: I am planning on buying an iMac to do the development on. I am hoping that OS X would give me a simple unix-like environment to get me up and running fast. Linux learning curve is too much for me to bear and Windows and XAMPP have been disappointing in the past.


There's not much more to comment than that it simply works fine with OS X... It seems that some of the core team do develop symfony on OS X boxes, so you won't risk to feel alone (at least I do not feel like that ;)~ ;-)~:wink :).

If you need some advise on tooling for which you can't find a proper solution in this forum, just ask. I'd be happy about any kind of exchange of experience on OS X-based web development tools.

Cheers RAPHAEL
User avatar
rschumacher
Faithful Member
 
Posts: 231
Joined: Wed Aug 15, 2007 3:28 pm
Location: Basel, Switzerland

Re: Can I use Askeet demo with Symphony 1.2.1?

by halfer » Mon Dec 15, 2008 11:28 am

All:

Askeet was designed for symfony 0.x, and can be made to work on 1.0.x with a bit of tweaking and adjustment. This is why it appears on the 1.0 documentation homepage only. If you want to learn the latest stable version, 1.2.x, then do the Jobeet tutorial, which is on the 1.2 pages.
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK

Re: Can I use Askeet demo with Symphony 1.2.1?

by mannerv » Mon Dec 15, 2008 11:58 am

Thanks for the info.

Is there any way to get the necessary components anymore (0.x Symfony, necessary PHP versions etc.) to get the Askeet demo up and running?

I would love to test if my idea for my site is any good and I think that the demo installed live would give me the info I need.
mannerv
Junior Member
 
Posts: 7
Joined: Sun Dec 14, 2008 4:12 pm

Re: Can I use Askeet demo with Symphony 1.2.1?

by halfer » Mon Dec 15, 2008 12:03 pm

If you look in the Askeet forum, someone's been releasing day tarballs (up to about day 16, which is fairly well progressed) for symfony 1.0.x. So, I'd personally install that version of symfony and then install the latest version of that work, and see how you get on. Ask questions in that forum if you get stuck (and do search the forum too, as many common problems have already been answered).
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK

Re: Can I use Askeet demo with Symphony 1.2.1?

by mannerv » Tue Dec 16, 2008 4:50 pm

Okay, sorry I jumped between forums, so one more extra question. And also, sorry for repeating myself, but as I am such a novice coder, I want to go in the "right direction" so as not to discourage myself by banging my head to some obstacle where I can not get through.

I noticed that there are many people at the Askeet topic with problems and I am seeing a lot of warnings about minor tweaking.

As halfer said, there are tarballs until day 16.

So, has anyone been able to get the Askeet demo to actually work with Symfony 1.0, besides of course the person who did the tutorial?

If not, is it still possible to install a version of the Symfony framework (which version? 0.?) and a PHP version with which it is possible to install the demo and / or finish the tutorials with relative ease?

I am trying to ask, do people have problems with the Askeet demo because of some changes to PHP, Symfony framework or what is the reason for the problems? I mean, the person who did the tutorial has gotten it to work and the site seems to live and kicking?

I am hoping to get into day 24 and beyond myself, but I do not wanna start off in the wrong direction. My goal here is to make an actual live ask and answer site and develop further, not to learn a specific framework version per se, so I have no specific reason to learn a specific technology.

Again, sorry my complicated messages. I really appreciate all the help everyone has given me so far!
mannerv
Junior Member
 
Posts: 7
Joined: Sun Dec 14, 2008 4:12 pm

Re: Can I use Askeet demo with Symphony 1.2.1?

by halfer » Thu Dec 18, 2008 11:58 am

I don't know if someone has definitively finished day 24 on symfony 1.0, but I am confident it is possible. I can't add anything other than repeating that you should try it on 1.0 - I really don't recommend trying it on old beta versions.
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK

Re: Can I use Askeet demo with Symphony 1.2.1?

by tm1978 » Fri Mar 20, 2009 12:28 pm

I finally got it to work :)~ :-)~ :smile:

Things that I encountered where numerous:

- PHP4/PHP5 problem - I has to change the symfony skript to "php5" instead of php
- SYMFONY needed to be renamed to symfony on Linux
- an existing Symfony installation I used instead of the one that is checked into the SVN
- changing the config files in the apps folder instead of the config folder at the top menu
- not using the build-all command
- not clearing the cache
tm1978
Junior Member
 
Posts: 24
Joined: Wed Mar 18, 2009 11:54 am

Re: Can I use Askeet demo with Symphony 1.2.1?

by halfer » Sat Mar 21, 2009 1:19 pm

@tm1978 - the first item is due to your hosting, not symfony. You would probably have had to do that with symfony 1.0, in my view.

Well done anyway for getting it to work. Did you use 1.1 or 1.2 in the end? Presumably you turned on 1.0 compatibility mode? Also, if you would post a tarball somewhere, and link to it here, I am sure it would be appreciated by some folks still interested in this project :D~ :-D~ :grin:
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK