This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use Stack Overflow.

Unable to generate module from non-existent model Question

Discussion around this tutorial for symfony 1.0.x

Unable to generate module from non-existent model Question

by kpatrick2 » Tue Jul 07, 2009 8:40 pm

Je viens de commencer avec symfony.
En essayant le projet askeet, voici le message d'erreur que la commande : $ symfony propel-generate-crud frontend question Question me retourne.

Unable to generate module from non-existent model Question

Svp aidez moi...
Qui nous séparera de l'amour de Jésus Christ
kpatrick2
Junior Member
 
Posts: 24
Joined: Tue Jun 30, 2009 9:26 pm

Re: Unable to generate module from non-existent model Question

by halfer » Wed Jul 08, 2009 10:58 pm

Try doing "symfony propel-generate-model" first. Make sure the table 'question' appears in your schema.xml/schema.yml before you do.
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK

Re: Unable to generate module from non-existent model Question

by halfer » Wed Jul 08, 2009 10:58 pm

Incidentally if you want to learn symfony, 1.2 is the recommended version, which can be tried out using the Jobeet tutorial.
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK

Re: Unable to generate module from non-existent model Question

by kpatrick2 » Thu Jul 09, 2009 1:43 pm

j'ai essayé la commande 'symfony propel-generate-model' mais jùobtien ce message : Task "symfony propel-generate-model" is not defined.
J'ai verifié le fichier schema.xml, il existe bien la table question.
Qui nous séparera de l'amour de Jésus Christ
kpatrick2
Junior Member
 
Posts: 24
Joined: Tue Jun 30, 2009 9:26 pm

Re: Unable to generate module from non-existent model Question

by halfer » Mon Jul 13, 2009 7:06 pm

Sorry, it should have been:

symfony propel-build-model

If you are ever in doubt, just type 'symfony' and you will get a list of commands.
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK

Re: Unable to generate module from non-existent model Question

by kpatrick2 » Mon Jul 13, 2009 8:21 pm

Merci beaucoup pour ton aide.
J'ai reussi a passer cet etape. Cette fois c'est une autre erreur que je recois.

Fatal error : Class 'QuestionForm' not found in C:\wamp\bin\php\php5.2.9-2\PEAR\symfony\generator\sfModelGen erator.class.php on line 321.

J'ai besoin que tu m'aide encore.
Qui nous séparera de l'amour de Jésus Christ
kpatrick2
Junior Member
 
Posts: 24
Joined: Tue Jun 30, 2009 9:26 pm

Re: Unable to generate module from non-existent model Question

by kpatrick2 » Tue Jul 14, 2009 6:10 pm

Je viens de trouver ce qui me manquait.
je devais excuter la commande
"symfony propel:build-forms"
merci pour ton aide.
Qui nous séparera de l'amour de Jésus Christ
kpatrick2
Junior Member
 
Posts: 24
Joined: Tue Jun 30, 2009 9:26 pm

Re: Unable to generate module from non-existent model Question

by halfer » Thu Jul 16, 2009 10:50 am

Ah... you are using symfony 1.2! I don't really recommend that - the Askeet tutorial does not use the forms system. You can switch a compatibility flag somewhere, but even so you will have a lot more work to do. If you are a highly experienced programmer, you can give it a go on 1.2, otherwise switch to 1.0.
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK

Re: Unable to generate module from non-existent model Question

by kpatrick2 » Thu Jul 16, 2009 11:40 am

Merci beaucoup pour l'attention que tu me porte.
Pour le moment, j'evolue bien. Des qu'il ya de nouvelle inquietudes, je t'informerai.
Qui nous séparera de l'amour de Jésus Christ
kpatrick2
Junior Member
 
Posts: 24
Joined: Tue Jun 30, 2009 9:26 pm

Re: Unable to generate module from non-existent model Question

by halfer » Thu Jul 16, 2009 12:55 pm

Pas de problème, mais je ne comprends pas - je ne parlez pas Français! :cry:
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK

Re: Unable to generate module from non-existent model Question

by kpatrick2 » Thu Jul 16, 2009 1:12 pm

I'll try next time to Express myself in english.
Qui nous séparera de l'amour de Jésus Christ
kpatrick2
Junior Member
 
Posts: 24
Joined: Tue Jun 30, 2009 9:26 pm

Re: Unable to generate module from non-existent model Question

by halfer » Fri Jul 17, 2009 10:32 am

Ha, well I wasn't being too serious, just trying out my schoolboy french! If you want to ask questions in your own language, try here:

http://groups.google.com/group/symfony-fr
halfer
Faithful Member
 
Posts: 10148
Joined: Mon Jan 30, 2006 1:16 pm
Location: West Midlands, UK