Installing a bundle without support for composer

Discuss Symfony 2 bundles here

Moderators: tiagojsag, dcobalt

Installing a bundle without support for composer

Postby matdev » Tue Dec 18, 2012 6:53 pm

Hello,

I am trying to install this bundle in my Symfony 2.1 project:
https://github.com/GaYAlab/IoFormBundle

The problem is that this bundle is for Symfony 2.0 with no support for Composer.

Is there a work around so that I can use it ?

Thanks
Mathias
matdev
Junior Member
 
Posts: 6
Joined: Thu Dec 06, 2012 10:23 am

Re: Installing a bundle without support for composer

Postby tiagojsag » Tue Dec 18, 2012 8:37 pm

Hi,

There's a composer.json in there, which means there's support for composer ;)

add this to you composer.json (not sure on the exact syntax, DO double check it)

Code: Select all
"gayalab/ioformbundle": "dev-master"


and run php composer.phar install
Tiago Garcia
@tiagojsag

Core Web Developer @ Shopware
http://www.shopware.de
User avatar
tiagojsag
Faithful Member
 
Posts: 885
Joined: Wed Aug 10, 2011 4:58 pm

Re: Installing a bundle without support for composer

Postby matdev » Tue Dec 18, 2012 11:45 pm

Indeed. I am unable to install it though.

When I run the composer update, I get the following message:
- gayalab/ioformbundle dev-master requires symfony/framework-bundle 2.0.*
matdev
Junior Member
 
Posts: 6
Joined: Thu Dec 06, 2012 10:23 am

Re: Installing a bundle without support for composer

Postby tiagojsag » Wed Dec 19, 2012 12:09 am

I'm not 100% sure, but i think that frameworkBundle uses the same version as symfony, so that would mean that that specific bundle requires sf2.0
Maybe try getting in touch with the project mantainer

cheers
Tiago Garcia
@tiagojsag

Core Web Developer @ Shopware
http://www.shopware.de
User avatar
tiagojsag
Faithful Member
 
Posts: 885
Joined: Wed Aug 10, 2011 4:58 pm

Re: Installing a bundle without support for composer

Postby matdev » Wed Dec 19, 2012 12:59 am

In fact maybe you could help me. I am looking for a datepicker for my form. Do you know any sf 2.1 compatible bundle I could use for that ?
matdev
Junior Member
 
Posts: 6
Joined: Thu Dec 06, 2012 10:23 am

Re: Installing a bundle without support for composer

Postby tiagojsag » Wed Dec 19, 2012 1:22 pm

Sorry, I'm a backend programmer, I don't use JS
Tiago Garcia
@tiagojsag

Core Web Developer @ Shopware
http://www.shopware.de
User avatar
tiagojsag
Faithful Member
 
Posts: 885
Joined: Wed Aug 10, 2011 4:58 pm

Re: Installing a bundle without support for composer

Postby dreipunktnull » Sun Dec 23, 2012 11:32 am

For a simple datepicker you don't need a full blown bundle IMHO. I always use the one that comes with jqueryui. BTW if you take a look at the sources of the bundle you are trying to install you'll see that it is in fact written for 2.0.x. Why not update it yourself and create a PR? I am sure the author would appreciate it.
User avatar
dreipunktnull
Faithful Member
 
Posts: 1244
Joined: Fri Jun 17, 2011 10:03 am
Location: Germany


Return to Bundles discussion

Who is online

Users browsing this forum: No registered users and 3 guests