Installing Symfony 2.1

Discuss installing Symfony 2 here

Moderators: tiagojsag, dcobalt

Installing Symfony 2.1

Postby hstoellinger » Thu Sep 06, 2012 11:51 pm

Hello,
Tried to run "php composer.phar create-project symfony/framework-standard-edition Test "
Following is the result. What's wrong? Thanks for your help.
Regards
H. Stoellinger
---------------------------------------------------------------
Installing symfony/framework-standard-edition (dev-master c61f0ed2fe9a90c1cc4b05bd420cee4633755b19)
- Installing symfony/framework-standard-edition (dev-master master)
Cloning master

Created project in Test
Loading composer repositories with package information
Installing dependencies from lock file
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for symfony/symfony == 2.1.9999999.9999999-dev -> satisfiable by symfony/symfony 2.1.x-dev.
- Can only install one of: symfony/symfony dev-master, symfony/symfony 2.1.x-dev.
- Installation request for symfony/symfony == 9999999-dev -> satisfiable by symfony/symfony dev-master.
hstoellinger
Junior Member
 
Posts: 2
Joined: Sun Jun 24, 2012 10:45 pm

Re: Installing Symfony 2.1

Postby WishCow » Fri Sep 07, 2012 11:53 am

I have the same problem, when trying to update from RC2 to the stable 2.1. I think the composer.json, and composer.lock files posted in the UPGRADE file on the official homepage are borked.

edit:

Now I can't even downgrade back to the old version, using the my old composer.lock file. Great.
WishCow
Junior Member
 
Posts: 15
Joined: Thu Aug 04, 2011 11:01 pm

Re: Installing Symfony 2.1

Postby bjo3rn » Fri Sep 07, 2012 12:24 pm

Exactly that cost me some time yesterday as well. What you need to do is fetch composer.json and composer.lock for Symfony standard edition and replace yours with these. If you added custom dependencies add them to the new composer.json, remove the vendor folder, run composer.phar install (which will complain about composer.lock not being in sync and abort at some point) and then run composer.phar update namespace/package for any of your custom dependencies. This will update composer.lock and everything should be fine again. At least this is what I did to fix my upgrades from RC2 to stable.
User avatar
bjo3rn
Faithful Member
 
Posts: 1244
Joined: Fri Jun 17, 2011 10:03 am
Location: Germany

Re: Installing Symfony 2.1

Postby squids » Mon Sep 10, 2012 7:04 pm

Hi, I had the same problem as the OP and ran 'composer.phar update' as told to when I tried 'composer.phar install' after reading the official update instructions.
Now I get
Fatal error: Class 'Symfony\Component\ClassLoader\UniversalClassLoader' not found in C:\xampp\htdocs\xxxxx\Symfony\app\autoload.php on line 6 Script Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap handling the post-update-cmd event terminated with an exception.

An error occurred when generating the bootstrap file.


When running either command. I'm new to Symfony and this is has cost me several hours of googling and left me pretty unimpressed to be honest.

Thanks for any help.
squids
Junior Member
 
Posts: 1
Joined: Mon Sep 10, 2012 6:53 pm

Re: Installing Symfony 2.1

Postby kreutzfeldt » Tue Sep 11, 2012 3:42 pm

Same problem still in 2.1.1

'php composer.phar install' Issues a warning that dependencies are out of sync and an update is required.

An 'php composer.phar update' still brings packages from development truncs.
kreutzfeldt
Junior Member
 
Posts: 1
Joined: Tue Sep 11, 2012 3:35 pm

Re: Installing Symfony 2.1

Postby bjo3rn » Tue Sep 11, 2012 8:05 pm

@kreutzfeldt: Did you add custom dependencies to composer.json? If so run
Code: Select all
composer.phar update namespace/package-name
to update composer.lock only for the added dependencies. If not make sure to use fresh copies of both composer.json and composer.lock from Symfony's repo.
User avatar
bjo3rn
Faithful Member
 
Posts: 1244
Joined: Fri Jun 17, 2011 10:03 am
Location: Germany

Re: Installing Symfony 2.1

Postby emolasses » Thu Sep 13, 2012 12:09 am

dreipunktnull wrote:Fatal error: Class 'Symfony\Component\ClassLoader\UniversalClassLoader' not found in C:\xampp\htdocs\xxxxx\Symfony\app\autoload.php on line 6 Script Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap handling the post-update-cmd event terminated with an exception.

An error occurred when generating the bootstrap file.


I'm getting the same error (quoted above) as squids. I haven't made any changes to composer.json or composer.lock. I downloaded the latest versions from Symfony Standard Edition (https://github.com/symfony/symfony-standard#readme). Not sure what i'm doing wrong, i'd appreciate any help thank you.
emolasses
Junior Member
 
Posts: 1
Joined: Wed Sep 12, 2012 7:01 pm

Re: Installing Symfony 2.1

Postby spearhead » Fri Sep 14, 2012 3:09 am

I can't get this to work either, can't even get close.

Using the file from here: (same place for lock) https://raw.github.com/symfony/symfony- ... poser.json
I get:
Code: Select all
Your lock file is out of sync with your composer.json, run "composer.phar update" to update dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for sensio/distribution-bundle == 2.1.9999999.9999999-dev -> satisfiable by sensio/distribution-bundle 2.1.x-dev.
    - Can only install one of: sensio/distribution-bundle dev-master, sensio/distribution-bundle 2.1.x-dev.
    - Installation request for sensio/distribution-bundle == 9999999-dev -> satisfiable by sensio/distribution-bundle dev-master.


Using the 2.1.1 tagged URL: https://raw.github.com/symfony/symfony- ... poser.json
I get the following after a few of the vendors have installed
Code: Select all
  - Installing twig/extensions (dev-master f904575)
    Cloning f904575642b1213db69b4a98f08397e722ba1cae

kriswallsmith/assetic suggests installing leafo/lessphp (Assetic provides the integration with the lessphp LESS compiler)
kriswallsmith/assetic suggests installing leafo/scssphp (Assetic provides the integration with the scssphp SCSS compiler)
kriswallsmith/assetic suggests installing ptachoire/cssembed (Assetic provides the integration with phpcssembed to embed data uris)
kriswallsmith/assetic suggests installing leafo/scssphp-compass (Assetic provides the integration with the SCSS compass plugin)
monolog/monolog suggests installing mlehner/gelf-php (Allow sending log messages to a GrayLog2 server)
monolog/monolog suggests installing ext-amqp (Allow sending log messages to an AMQP server (1.0+ required))
monolog/monolog suggests installing ext-mongo (Allow sending log messages to a MongoDB server)
Generating autoload files

Script Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap handling the post-install-cmd event terminated with an exception
                                                         
[RuntimeException]                                     
 An error occurred when generating the bootstrap file.


Attempting to run composer.phar update gives me this:

Code: Select all
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - symfony/swiftmailer-bundle 2.1.x-dev requires symfony/swiftmailer-bridge 2.1.* -> satisfiable by symfony/symfony 2.1.x-dev, symfony/swiftmailer-bridge v2.1.0, symfony/swiftmailer-bridge v2.1.0-RC2, symfony/symfony v2.1.0-RC1, symfony/symfony v2.1.0-RC2, symfony/swiftmailer-bridge v2.1.0-BETA3, symfony/swiftmailer-bridge v2.1.0-BETA4, symfony/swiftmailer-bridge v2.1.0-RC1, symfony/symfony v2.1.0-BETA2, symfony/symfony v2.1.0-BETA3, symfony/symfony v2.1.0-BETA4, symfony/swiftmailer-bridge v2.1.0-BETA1, symfony/symfony 2.1.x-dev, symfony/swiftmailer-bridge v2.1.1, symfony/symfony v2.1.0, symfony/symfony v2.1.1, symfony/swiftmailer-bridge v2.1.0-BETA2, symfony/symfony v2.1.0-BETA1, symfony/swiftmailer-bridge 2.1.x-dev.
    - symfony/swiftmailer-bundle v2.1.0 requires symfony/swiftmailer-bridge 2.1.* -> satisfiable by symfony/symfony 2.1.x-dev, symfony/swiftmailer-bridge v2.1.0, symfony/swiftmailer-bridge v2.1.0-RC2, symfony/symfony v2.1.0-RC1, symfony/symfony v2.1.0-RC2, symfony/swiftmailer-bridge v2.1.0-BETA3, symfony/swiftmailer-bridge v2.1.0-BETA4, symfony/swiftmailer-bridge v2.1.0-RC1, symfony/symfony v2.1.0-BETA2, symfony/symfony v2.1.0-BETA3, symfony/symfony v2.1.0-BETA4, symfony/swiftmailer-bridge v2.1.0-BETA1, symfony/symfony 2.1.x-dev, symfony/swiftmailer-bridge v2.1.1, symfony/symfony v2.1.0, symfony/symfony v2.1.1, symfony/swiftmailer-bridge v2.1.0-BETA2, symfony/symfony v2.1.0-BETA1, symfony/swiftmailer-bridge 2.1.x-dev.
    - symfony/swiftmailer-bundle v2.1.0-RC2 requires symfony/swiftmailer-bridge 2.1.* -> satisfiable by symfony/symfony 2.1.x-dev, symfony/swiftmailer-bridge v2.1.0, symfony/swiftmailer-bridge v2.1.0-RC2, symfony/symfony v2.1.0-RC1, symfony/symfony v2.1.0-RC2, symfony/swiftmailer-bridge v2.1.0-BETA3, symfony/swiftmailer-bridge v2.1.0-BETA4, symfony/swiftmailer-bridge v2.1.0-RC1, symfony/symfony v2.1.0-BETA2, symfony/symfony v2.1.0-BETA3, symfony/symfony v2.1.0-BETA4, symfony/swiftmailer-bridge v2.1.0-BETA1, symfony/symfony 2.1.x-dev, symfony/swiftmailer-bridge v2.1.1, symfony/symfony v2.1.0, symfony/symfony v2.1.1, symfony/swiftmailer-bridge v2.1.0-BETA2, symfony/symfony v2.1.0-BETA1, symfony/swiftmailer-bridge 2.1.x-dev.
    - symfony/swiftmailer-bundle 2.1.x-dev requires symfony/swiftmailer-bridge 2.1.* -> satisfiable by symfony/symfony 2.1.x-dev, symfony/swiftmailer-bridge v2.1.0, symfony/swiftmailer-bridge v2.1.0-RC2, symfony/symfony v2.1.0-RC1, symfony/symfony v2.1.0-RC2, symfony/swiftmailer-bridge v2.1.0-BETA3, symfony/swiftmailer-bridge v2.1.0-BETA4, symfony/swiftmailer-bridge v2.1.0-RC1, symfony/symfony v2.1.0-BETA2, symfony/symfony v2.1.0-BETA3, symfony/symfony v2.1.0-BETA4, symfony/swiftmailer-bridge v2.1.0-BETA1, symfony/symfony 2.1.x-dev, symfony/swiftmailer-bridge v2.1.1, symfony/symfony v2.1.0, symfony/symfony v2.1.1, symfony/swiftmailer-bridge v2.1.0-BETA2, symfony/symfony v2.1.0-BETA1, symfony/swiftmailer-bridge 2.1.x-dev.
    - Can only install one of: symfony/symfony 2.2.x-dev, symfony/symfony 2.1.x-dev.
    - Can only install one of: symfony/symfony 2.2.x-dev, symfony/symfony v2.1.0-RC1.
    - Can only install one of: symfony/symfony 2.2.x-dev, symfony/symfony v2.1.0-RC2.
    - Can only install one of: symfony/symfony 2.2.x-dev, symfony/symfony v2.1.0-BETA2.
    - Can only install one of: symfony/symfony 2.2.x-dev, symfony/symfony v2.1.0-BETA3.
    - Can only install one of: symfony/symfony 2.2.x-dev, symfony/symfony v2.1.0-BETA4.
    - Can only install one of: symfony/symfony 2.2.x-dev, symfony/symfony 2.1.x-dev.
    - Can only install one of: symfony/symfony v2.1.0, symfony/symfony 2.2.x-dev.
    - Can only install one of: symfony/symfony v2.1.1, symfony/symfony 2.2.x-dev.
    - Can only install one of: symfony/symfony v2.1.0-BETA1, symfony/symfony 2.2.x-dev.
    - don't install symfony/symfony 2.2.x-dev|don't install symfony/swiftmailer-bridge v2.1.0
    - don't install symfony/symfony 2.2.x-dev|don't install symfony/swiftmailer-bridge v2.1.0-RC2
    - don't install symfony/symfony 2.2.x-dev|don't install symfony/swiftmailer-bridge v2.1.0-BETA3
    - don't install symfony/symfony 2.2.x-dev|don't install symfony/swiftmailer-bridge v2.1.0-BETA4
    - don't install symfony/symfony 2.2.x-dev|don't install symfony/swiftmailer-bridge v2.1.0-RC1
    - don't install symfony/symfony 2.2.x-dev|don't install symfony/swiftmailer-bridge v2.1.0-BETA1
    - don't install symfony/swiftmailer-bridge v2.1.1|don't install symfony/symfony 2.2.x-dev
    - don't install symfony/swiftmailer-bridge v2.1.0-BETA2|don't install symfony/symfony 2.2.x-dev
    - don't install symfony/swiftmailer-bridge 2.1.x-dev|don't install symfony/symfony 2.2.x-dev
    - Installation request for symfony/symfony 2.2.* -> satisfiable by symfony/symfony 2.2.x-dev.
    - Installation request for symfony/swiftmailer-bundle 2.1.* -> satisfiable by symfony/swiftmailer-bundle 2.1.x-dev, symfony/swiftmailer-bundle v2.1.0, symfony/swiftmailer-bundle v2.1.0-RC2.



My setup passes app/check.php no problems, everyone was working fine and dandy with 2.0, I have deleted the vendors folder before performing any of the above steps. Glad I'm not the only one having issues!
spearhead
Junior Member
 
Posts: 24
Joined: Sat Jan 21, 2012 2:06 am

Re: Installing Symfony 2.1

Postby drebbinps » Fri Sep 14, 2012 2:12 pm

Hi

I am brand new to this so sorry if this reply is no good or already tried.

I had the same problem so I added the version number 2.1.1 to the end of the php command as per these posts

http://stackoverflow.com/questions/12313931/error-creating-symfony2-project-from-composer
https://github.com/symfony/symfony-standard/issues/406

Everything worked fine after that.

Hope this helps.

F
drebbinps
Junior Member
 
Posts: 1
Joined: Fri Sep 14, 2012 2:02 pm

Re: Installing Symfony 2.1

Postby spearhead » Tue Sep 18, 2012 3:03 am

Clean symfony intall of 2.1 downloaded directly from the site one hour ago.

Code: Select all
composer.phar update


Code: Select all
Generating autoload files
Script Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap handling the post-update-cmd event terminated with an exception                                       
 [RuntimeException]                                     
 An error occurred when generating the bootstrap file.

spearhead
Junior Member
 
Posts: 24
Joined: Sat Jan 21, 2012 2:06 am

Re: Installing Symfony 2.1

Postby Crulaz » Wed Sep 19, 2012 10:07 am

Hi guys,

I have got exactly the same problem than spearhead :-(

I'm confused because it seems there is not issue. Somebody found a solution?

Thanks a lot for your help.
Crulaz
Junior Member
 
Posts: 2
Joined: Wed Sep 19, 2012 9:59 am

Re: Installing Symfony 2.1

Postby Crulaz » Wed Sep 19, 2012 9:57 pm

Below that happens when I just downloaded composer.phar and apply the instructions of installation according to the install documentation.

Code: Select all
eric@ubuntu:~/lpm/test$ curl -s https://getcomposer.org/installer | php
#!/usr/bin/env php
Some settings on your machine may cause stability issues with Composer.
If you encounter issues, try to change the following:

The date.timezone setting should be provided.
Add the following to the end of your `php.ini`:
    ; UTC here is an example, use your own timezone, see http://www.php.net/manual/en/timezones.php
    date.timezone = UTC

Downloading...

Composer successfully installed to: /home/eric/lpm/test/composer.phar
Use it: php composer.phar
eric@ubuntu:~/lpm/test$ php composer.phar create-project symfony/framework-standard-edition path/ 2.1.1
Installing symfony/framework-standard-edition (v2.1.1)
  - Installing symfony/framework-standard-edition (v2.1.1)
    Downloading: 100%         

Created project in path/
Loading composer repositories with package information
Installing dependencies from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install symfony/symfony 2.1.x-dev
    - sensio/generator-bundle 2.2.x-dev requires symfony/framework-bundle 2.2.* -> satisfiable by symfony/framework-bundle 2.2.x-dev, symfony/symfony 2.2.x-dev.
    - sensio/generator-bundle 2.2.x-dev requires symfony/framework-bundle 2.2.* -> satisfiable by symfony/framework-bundle 2.2.x-dev, symfony/symfony 2.2.x-dev.
    - Can only install one of: symfony/symfony 2.2.x-dev, symfony/symfony 2.1.x-dev.
    - don't install symfony/symfony 2.1.x-dev|don't install symfony/framework-bundle 2.2.x-dev
    - Installation request for symfony/symfony == 2.1.9999999.9999999-dev -> satisfiable by symfony/symfony 2.1.x-dev.
    - Installation request for sensio/generator-bundle == 2.2.9999999.9999999-dev -> satisfiable by sensio/generator-bundle 2.2.x-dev.
Crulaz
Junior Member
 
Posts: 2
Joined: Wed Sep 19, 2012 9:59 am

Re: Installing Symfony 2.1

Postby Mr. Tool » Thu Sep 20, 2012 9:05 am

Install composer.phar and execute
Code: Select all
php composer.phar create-project symfony/framework-standard-edition path/ 2.1.1


copy composer.phar into the "path/" directory or wether where the composer.json file is.

delete the composer.lock

run
Code: Select all
php composer.phar install


Have fun developing with symfony
Mr. Tool
Member
 
Posts: 72
Joined: Fri May 27, 2011 11:37 am

Re: Installing Symfony 2.1

Postby spearhead » Thu Nov 29, 2012 11:04 pm

For anyone still struggling with this bug, here is the (likely) solution:

The upgrade doc does shows to run
Code: Select all
composer.phar install
as one of the first steps, this WILL NOT work. You must follow the rest of that document, make the required changes to the existing files, then run composer.phar install. To be safe I'd recommend deleting the composer.lock file and starting from scratch.
spearhead
Junior Member
 
Posts: 24
Joined: Sat Jan 21, 2012 2:06 am

Re: Installing Symfony 2.1

Postby jharny » Wed Feb 27, 2013 4:40 pm

I ended up hhaving to delete the composer.lock file but got it sorted eventually, thanks
Henry I love viviscal. Learn about it in viviscal reviews, this viviscal review is good.
jharny
Junior Member
 
Posts: 1
Joined: Wed Feb 27, 2013 4:37 pm

Re: Installing Symfony 2.1

Postby miliksitek » Sat Sep 07, 2013 2:26 pm

spearhead wrote:For anyone still struggling with this bug, here is the (likely) solution:

The upgrade doc does shows to run
Code: Select all
composer.phar install
as one of the first steps, this WILL NOT work. You must follow the rest of that document, make the required changes to the existing files, then run composer.phar install. To be safe I'd recommend deleting the composer.lock file and starting from scratch.

This worked for me! Many thanks!
miliksitek
Junior Member
 
Posts: 3
Joined: Sat Sep 07, 2013 11:07 am

Re: Installing Symfony 2.1

Postby hello_kitty » Fri May 09, 2014 10:00 am

Is it possible to get install documentation about version 2.1?
hello_kitty
Junior Member
 
Posts: 3
Joined: Fri May 09, 2014 9:47 am

Re: Installing Symfony 2.1

Postby LandsGrieco » Tue Jun 24, 2014 6:14 pm

Same problem still in 2.1
LandsGrieco
Junior Member
 
Posts: 1
Joined: Tue Jun 24, 2014 4:43 pm
Location: 1360 W. 9th Street, Suite 200


Return to Installation and setup

Who is online

Users browsing this forum: No registered users and 2 guests