Error during the installation Symfony 2.1.7

Discuss installing Symfony 2 here

Moderators: tiagojsag, dcobalt

Error during the installation Symfony 2.1.7

Postby mimu » Sun Jan 20, 2013 12:51 pm

Hi,

I wanted to install Symfony 2.1.7. but I got some errors during the installation. I had tried this command:

sudo php composer.phar create-project symfony/framework-standard-edition testSymfony/ 2.1.7

and I got this error message:

[RuntimeException]
Failed to clone http://github.com/kriswallsmith/assetic.git, git was not found, check that it is installed and in your PATH env.

sh: 1: git: not found

I'm using Ubuntu Linux, PHP 5.3, Apache 2.

Any idea? :) Thank you!
mimu
Junior Member
 
Posts: 3
Joined: Fri Sep 07, 2012 3:20 pm

Re: Error during the installation Symfony 2.1.7

Postby dreipunktnull » Sun Jan 20, 2013 3:57 pm

mimu wrote:sh: 1: git: not found

I'm using Ubuntu Linux


What should I say? git is not installed :D

Code: Select all
sudo apt-get install git

should help.
User avatar
dreipunktnull
Faithful Member
 
Posts: 1244
Joined: Fri Jun 17, 2011 10:03 am
Location: Germany

Re: Error during the installation Symfony 2.1.7

Postby mimu » Sun Jan 20, 2013 4:53 pm

:-) omg... it was the "big" problem :D

thank you. :)))
mimu
Junior Member
 
Posts: 3
Joined: Fri Sep 07, 2012 3:20 pm

Re: Error during the installation Symfony 2.1.7

Postby MichaelCollinson » Wed Feb 06, 2013 6:50 pm

I have the same problem running Windows XP.

I have installed the Windows GitHub application. How do I get Composer to recognise it?
MichaelCollinson
Junior Member
 
Posts: 1
Joined: Wed Feb 06, 2013 6:45 pm

Re: Error during the installation Symfony 2.1.7

Postby dreipunktnull » Fri Feb 08, 2013 7:36 pm

You need to install a git client for the CLI and this would most probably be msysgit
User avatar
dreipunktnull
Faithful Member
 
Posts: 1244
Joined: Fri Jun 17, 2011 10:03 am
Location: Germany


Return to Installation and setup

Who is online

Users browsing this forum: No registered users and 4 guests